Conaito.PowerLight

conaito Powerlight SDK 1.2

Conaito.PowerLight Namespace

Namespace Hierarchy

Classes

Class | Description
ConvertingSettings | ConvertingSettings class
DocumentInfo | PowerPoint or XPS document info
LicenseInfo | LicenseInfo class
PowerPointConverter | PowerPointConverter class
PresentationInfo | PresentationInfo class

Delegates

Delegate | Description
PowerPointConverter.SlideProcessedHandler | Slide processed delegate

Enumerations

Enumeration | Description
ImageFormat | Output image format
ImageQuality | Output image format
ImageStretch | Describes how content is resized to fill its allocated space.
LicenseMode | License modes enum
SlideTransition | Slide transition type
TestEnvironmentResult |

Send comments on this topic.

© conaito Technologies 2010


ConvertingSettings Class

ConvertingSettings class

For a list of all members of this type, see ConvertingSettings Members .

System.Object
ConvertingSettings

[Visual Basic]
Public Class ConvertingSettings
[C#]
public class ConvertingSettings

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PowerLight

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

ConvertingSettings Members | Conaito.PowerLight Namespace


ConvertingSettings Members

ConvertingSettings overview

Public Static (Shared) Methods

LoadFromXML Loads from XML.

Public Instance Constructors

ConvertingSettings Constructor Initializes a new instance of the ConvertingSettings class.

Public Instance Properties

AutoPlaySlideShow | Gets or sets a value indicating whether [auto play slide show].
ImageFormat | Image format
ImageQuality | Image quality
ImageStretch | Gets or sets the image stretch.
SlideShowCaption | Gets or sets the slide show caption.
SlideTimeout | Gets or sets the slide timeout.
SlideTransition | Gets or sets the slide transition.
TransitionDuration | Gets or sets the duration of the transition.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SaveToXML | Saves to XML.
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ConvertingSettings Class | Conaito.PowerLight Namespace


ConvertingSettings Constructor

Initializes a new instance of the ConvertingSettings class.

[Visual Basic]
Public Sub New()
[C#]
ConvertingSettings();

See Also

ConvertingSettings Class | Conaito.PowerLight Namespace


ConvertingSettings Properties

The properties of the ConvertingSettings class are listed below. For a complete list of ConvertingSettings class members, see the ConvertingSettings Members topic.

Public Instance Properties

AutoPlaySlideShow | Gets or sets a value indicating whether [auto play slide show].
ImageFormat | Image format
ImageQuality | Image quality
ImageStretch | Gets or sets the image stretch.
SlideShowCaption | Gets or sets the slide show caption.
SlideTimeout | Gets or sets the slide timeout.
SlideTransition | Gets or sets the slide transition.
TransitionDuration | Gets or sets the duration of the transition.

See Also

ConvertingSettings Class | Conaito.PowerLight Namespace


AutoPlaySlideShow Property

conaito Powerlight SDK 1.2

ConvertingSettings.AutoPlaySlideShow Property

Gets or sets a value indicating whether [auto play slide show].

[Visual Basic]
Public Property AutoPlaySlideShow() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool AutoPlaySlideShow { public get; public set; }

Property Value

true if [auto play slide show]; otherwise, false.

See Also

ConvertingSettings Class | Conaito.PowerLight Namespace


ImageFormat Property

conaito Powerlight SDK 1.2

ConvertingSettings.ImageFormat Property

Image format

[Visual Basic]
Public Property ImageFormat() As ImageFormat
Public Get
End Get
Public Set
End Set
End Property
[C#]
public ImageFormat ImageFormat { public get; public set; }

See Also

ConvertingSettings Class | Conaito.PowerLight Namespace


ImageQuality Property

conaito Powerlight SDK 1.2

ConvertingSettings.ImageQuality Property

Image quality

[Visual Basic]
Public Property ImageQuality() As ImageQuality
Public Get
End Get
Public Set
End Set
End Property
[C#]
public ImageQuality ImageQuality { public get; public set; }

See Also

ConvertingSettings Class | Conaito.PowerLight Namespace


ImageStretch Property

conaito Powerlight SDK 1.2

ConvertingSettings.ImageStretch Property

Gets or sets the image stretch.

[Visual Basic]
Public Property ImageStretch() As ImageStretch
Public Get
End Get
Public Set
End Set
End Property
[C#]
public ImageStretch ImageStretch { public get; public set; }

Property Value

The image stretch.

See Also

ConvertingSettings Class | Conaito.PowerLight Namespace


SlideShowCaption Property

conaito Powerlight SDK 1.2

ConvertingSettings.SlideShowCaption Property

Gets or sets the slide show caption.

[Visual Basic]
Public Property SlideShowCaption() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
public string SlideShowCaption { public get; public set; }

Property Value

The slide show caption.

See Also

ConvertingSettings Class | Conaito.PowerLight Namespace


SlideTimeout Property

conaito Powerlight SDK 1.2

ConvertingSettings.SlideTimeout Property

Gets or sets the slide timeout.

[Visual Basic]
Public Property SlideTimeout() As Integer
Public Get
End Get
Public Set
End Set
End Property
[C#]
public int SlideTimeout { public get; public set; }

Property Value

The slide timeout.

See Also

ConvertingSettings Class | Conaito.PowerLight Namespace


SlideTransition Property

conaito Powerlight SDK 1.2

ConvertingSettings.SlideTransition Property

Gets or sets the slide transition.

[Visual Basic]
Public Property SlideTransition() As SlideTransition
Public Get
End Get
Public Set
End Set
End Property
[C#]
public SlideTransition SlideTransition { public get; public set; }

Property Value

The slide transition.

See Also

ConvertingSettings Class | Conaito.PowerLight Namespace


TransitionDuration Property

conaito Powerlight SDK 1.2

ConvertingSettings.TransitionDuration Property

Gets or sets the duration of the transition.

[Visual Basic]
Public Property TransitionDuration() As Single
Public Get
End Get
Public Set
End Set
End Property
[C#]
public float TransitionDuration { public get; public set; }

Property Value

The duration of the transition.

See Also

ConvertingSettings Class | Conaito.PowerLight Namespace


ConvertingSettings Methods

The methods of the ConvertingSettings class are listed below. For a complete list of ConvertingSettings class members, see the ConvertingSettings Members topic.

Public Static (Shared) Methods

LoadFromXML Loads from XML.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
SaveToXML | Saves to XML.
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ConvertingSettings Class | Conaito.PowerLight Namespace


ConvertingSettings.LoadFromXML Method

Loads from XML.

[Visual Basic]
Public Shared Sub LoadFromXML()
[C#]
public static ConvertingSettings LoadFromXML();

Return Value

See Also

ConvertingSettings Class | Conaito.PowerLight Namespace


ConvertingSettings.SaveToXML Method

Saves to XML.

[Visual Basic]
Public Sub SaveToXML()
[C#]
public void SaveToXML();

See Also

ConvertingSettings Class | Conaito.PowerLight Namespace


DocumentInfo Class

PowerPoint or XPS document info

For a list of all members of this type, see DocumentInfo Members .

System.Object
DocumentInfo

[Visual Basic]
Public Class DocumentInfo
[C#]
public class DocumentInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PowerLight

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

DocumentInfo Members | Conaito.PowerLight Namespace


DocumentInfo Members

DocumentInfo overview

Public Instance Properties

Path | PowerPoint or XPS file path
SlidesCount | Slides count in PowerPoint or XPS file

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

DocumentInfo Class | Conaito.PowerLight Namespace


DocumentInfo Properties

The properties of the DocumentInfo class are listed below. For a complete list of DocumentInfo class members, see the DocumentInfo Members topic.

Public Instance Properties

Path | PowerPoint or XPS file path
SlidesCount | Slides count in PowerPoint or XPS file

See Also

DocumentInfo Class | Conaito.PowerLight Namespace


Path Property

conaito Powerlight SDK 1.2

DocumentInfo.Path Property

PowerPoint or XPS file path

[Visual Basic]
Public Property Path() As String
Public Get
End Get
Private Set
End Set
End Property
[C#]
public string Path { public get; private set; }

See Also

DocumentInfo Class | Conaito.PowerLight Namespace


SlidesCount Property

conaito Powerlight SDK 1.2

DocumentInfo.SlidesCount Property

Slides count in PowerPoint or XPS file

[Visual Basic]
Public Property SlidesCount() As Integer
Public Get
End Get
Private Set
End Set
End Property
[C#]
public int SlidesCount { public get; private set; }

See Also

DocumentInfo Class | Conaito.PowerLight Namespace


ImageFormat Enumeration

Output image format

[Visual Basic]
Public Enum ImageFormat
[C#]
public enum ImageFormat

Members

Member Name | Description
Jpeg | Jpeg format
Png | Png format

Requirements

Namespace: Conaito.PowerLight

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

Conaito.PowerLight Namespace


ImageQuality Enumeration

Output image format

[Visual Basic]
Public Enum ImageQuality
[C#]
public enum ImageQuality

Members

Member Name | Description
Low | Low quality
Normal | Normal quality
Highly | Highly quality

Requirements

Namespace: Conaito.PowerLight

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

Conaito.PowerLight Namespace


ImageStretch Enumeration

Describes how content is resized to fill its allocated space.

[Visual Basic]
Public Enum ImageStretch
[C#]
public enum ImageStretch

Members

Member Name | Description
None | The content preserves its original size.
Fill | The content is resized to fill the destination dimensions. The aspect ratio is not preserved.
Uniform | The content is resized to fit in the destination dimensions while it preserves its native aspect ratio.
UniformToFill | The content is resized to fill the destination dimensions while it preserves its native aspect ratio. If the aspect ratio of the destination rectangle differs from the source, the source content is clipped to fit in the destination dimensions.

Requirements

Namespace: Conaito.PowerLight

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

Conaito.PowerLight Namespace


LicenseInfo Class

LicenseInfo class

For a list of all members of this type, see LicenseInfo Members .

System.Object
LicenseInfo

[Visual Basic]
Public Class LicenseInfo
[C#]
public class LicenseInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PowerLight

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

LicenseInfo Members | Conaito.PowerLight Namespace


LicenseInfo Members

LicenseInfo overview

Public Instance Properties

Customer |
LicenseKey | Gets the license key.
LicenseMode | Gets the license mode.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetLicenseDateExpired | Gets the license date expired.
GetType (inherited from Object) |
IsLicenseValid | Determines whether license is Full or Trial.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

LicenseInfo Class | Conaito.PowerLight Namespace


LicenseInfo Properties

The properties of the LicenseInfo class are listed below. For a complete list of LicenseInfo class members, see the LicenseInfo Members topic.

Public Instance Properties

Customer |
LicenseKey | Gets the license key.
LicenseMode | Gets the license mode.

See Also

LicenseInfo Class | Conaito.PowerLight Namespace


Customer Property

conaito Powerlight SDK 1.2

LicenseInfo.Customer Property

[Visual Basic]
Public Property Customer() As String
Public Get
End Get
Private Set
End Set
End Property
[C#]
public string Customer { public get; private set; }

See Also

LicenseInfo Class | Conaito.PowerLight Namespace


LicenseKey Property

conaito Powerlight SDK 1.2

LicenseInfo.LicenseKey Property

Gets the license key.

[Visual Basic]
Public Property LicenseKey() As String
Public Get
End Get
Private Set
End Set
End Property
[C#]
public string LicenseKey { public get; private set; }

Property Value

The license key.

See Also

LicenseInfo Class | Conaito.PowerLight Namespace


LicenseMode Property

conaito Powerlight SDK 1.2

LicenseInfo.LicenseMode Property

Gets the license mode.

[Visual Basic]
Public Property LicenseMode() As LicenseMode
Public Get
End Get
Private Set
End Set
End Property
[C#]
public LicenseMode LicenseMode { public get; private set; }

Property Value

The license mode.

See Also

LicenseInfo Class | Conaito.PowerLight Namespace


LicenseInfo Methods

The methods of the LicenseInfo class are listed below. For a complete list of LicenseInfo class members, see the LicenseInfo Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetLicenseDateExpired | Gets the license date expired.
GetType (inherited from Object) |
IsLicenseValid | Determines whether license is Full or Trial.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

LicenseInfo Class | Conaito.PowerLight Namespace


LicenseInfo.GetLicenseDateExpired Method

Gets the license date expired.

[Visual Basic]
Public Sub GetLicenseDateExpired()
[C#]
public string GetLicenseDateExpired();

Return Value

See Also

LicenseInfo Class | Conaito.PowerLight Namespace


LicenseInfo.IsLicenseValid Method

Determines whether license is Full or Trial.

[Visual Basic]
Public Sub IsLicenseValid()
[C#]
public bool IsLicenseValid();

Return Value

true if license is Full or Trial; otherwise, false.

See Also

LicenseInfo Class | Conaito.PowerLight Namespace


LicenseInfo.ToString Method

Returns a String that represents this instance.

[Visual Basic]
Public Overrides Sub ToString()
[C#]
public override string ToString();

Return Value

A String that represents this instance.

See Also

LicenseInfo Class | Conaito.PowerLight Namespace


LicenseMode Enumeration

License modes enum

[Visual Basic]
Public Enum LicenseMode
[C#]
public enum LicenseMode

Members

Member Name | Description
LM_TRIAL | Trial mode
LM_TRIAL_DATE_EXPIRED | Trial date expired mode
LM_FULL | Full mode
LM_FULL_DATE_EXPIRED | Full date expired mode

Requirements

Namespace: Conaito.PowerLight

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

Conaito.PowerLight Namespace


PowerPointConverter Class

PowerPointConverter class

For a list of all members of this type, see PowerPointConverter Members .

System.Object
PowerPointConverter

[Visual Basic]
Public Class PowerPointConverter
[C#]
public class PowerPointConverter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PowerLight

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

PowerPointConverter Members | Conaito.PowerLight Namespace


PowerPointConverter Members

PowerPointConverter overview

Public Instance Constructors

PowerPointConverter Constructor Initializes a new instance of the PowerPointConverter class.

Public Instance Properties

CustomLogo | Gets or sets the custom banner. Works only on FULL license mode.
Document | PowerPoint or XPS document information
LicenseInfo | Gets or sets the license info.
Settings | The Convertion settings

Public Instance Methods

ConvertToSilverlight | Convert to Silverlight Slideshow
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
OpenPowerPointFile | Open PowerPoint document
OpenXPSDocument | Opens the XPS document.
SetLicense | Set license key
ToString (inherited from Object) |

Public Instance Events

SlideProcessed Occurs when [slide processed].

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

PowerPointConverter Class | Conaito.PowerLight Namespace


PowerPointConverter Constructor

Initializes a new instance of the PowerPointConverter class.

[Visual Basic]
Public Sub New()
[C#]
PowerPointConverter();

See Also

PowerPointConverter Class | Conaito.PowerLight Namespace


PowerPointConverter Properties

The properties of the PowerPointConverter class are listed below. For a complete list of PowerPointConverter class members, see the PowerPointConverter Members topic.

Public Instance Properties

CustomLogo | Gets or sets the custom banner. Works only on FULL license mode.
Document | PowerPoint or XPS document information
LicenseInfo | Gets or sets the license info.
Settings | The Convertion settings

See Also

PowerPointConverter Class | Conaito.PowerLight Namespace


CustomLogo Property

conaito Powerlight SDK 1.2

PowerPointConverter.CustomLogo Property

Gets or sets the custom banner. Works only on FULL license mode.

[Visual Basic]
Public Property CustomLogo() As Bitmap
Public Get
End Get
Public Set
End Set
End Property
[C#]
public Bitmap CustomLogo { public get; public set; }

Property Value

The custom banner.

See Also

PowerPointConverter Class | Conaito.PowerLight Namespace


Document Property

conaito Powerlight SDK 1.2

PowerPointConverter.Document Property

PowerPoint or XPS document information

[Visual Basic]
Public Property Document() As DocumentInfo
Public Get
End Get
Private Set
End Set
End Property
[C#]
public DocumentInfo Document { public get; private set; }

See Also

PowerPointConverter Class | Conaito.PowerLight Namespace


LicenseInfo Property

conaito Powerlight SDK 1.2

PowerPointConverter.LicenseInfo Property

Gets or sets the license info.

[Visual Basic]
Public Property LicenseInfo() As LicenseInfo
Public Get
End Get
Private Set
End Set
End Property
[C#]
public LicenseInfo LicenseInfo { public get; private set; }

Property Value

The license info.

See Also

PowerPointConverter Class | Conaito.PowerLight Namespace


Settings Property

conaito Powerlight SDK 1.2

PowerPointConverter.Settings Property

The Convertion settings

[Visual Basic]
Public Property Settings() As ConvertingSettings
Public Get
End Get
Public Set
End Set
End Property
[C#]
public ConvertingSettings Settings { public get; public set; }

See Also

PowerPointConverter Class | Conaito.PowerLight Namespace


PowerPointConverter Methods

The methods of the PowerPointConverter class are listed below. For a complete list of PowerPointConverter class members, see the PowerPointConverter Members topic.

Public Instance Methods

ConvertToSilverlight | Convert to Silverlight Slideshow
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
OpenPowerPointFile | Open PowerPoint document
OpenXPSDocument | Opens the XPS document.
SetLicense | Set license key
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

PowerPointConverter Class | Conaito.PowerLight Namespace


PowerPointConverter.ConvertToSilverlight Method

Convert to Silverlight Slideshow

[Visual Basic]
Public Sub ConvertToSilverlight( _
ByVal outputFolder As String _
)
[C#]
public void ConvertToSilverlight(
string outputFolder
);

Parameters

outputFolder
The output folder.

See Also

PowerPointConverter Class | Conaito.PowerLight Namespace


PowerPointConverter.OpenPowerPointFile Method

Open PowerPoint document

[Visual Basic]
Public Sub OpenPowerPointFile( _
ByVal powerPointFilePath As String _
)
[C#]
public void OpenPowerPointFile(
string powerPointFilePath
);

Parameters

powerPointFilePath
The PowerPoint file path.

See Also

PowerPointConverter Class | Conaito.PowerLight Namespace


PowerPointConverter.OpenXPSDocument Method

Opens the XPS document.

[Visual Basic]
Public Sub OpenXPSDocument( _
ByVal xpsDocumentFilePath As String _
)
[C#]
public void OpenXPSDocument(
string xpsDocumentFilePath
);

Parameters

xpsDocumentFilePath
The XPS document file path.

See Also

PowerPointConverter Class | Conaito.PowerLight Namespace


PowerPointConverter.SetLicense Method

Set license key

[Visual Basic]
Public Sub SetLicense( _
ByVal licenseKey As String _
)
[C#]
public void SetLicense(
string licenseKey
);

Parameters

licenseKey

See Also

PowerPointConverter Class | Conaito.PowerLight Namespace


PowerPointConverter Events

The events of the PowerPointConverter class are listed below. For a complete list of PowerPointConverter class members, see the PowerPointConverter Members topic.

Public Instance Events

SlideProcessed Occurs when [slide processed].

See Also

PowerPointConverter Class | Conaito.PowerLight Namespace


PowerPointConverter.SlideProcessed Event

Occurs when [slide processed].

[Visual Basic]
Public Event SlideProcessed As SlideProcessedHandler
[C#]
public event SlideProcessedHandler SlideProcessed;

See Also

PowerPointConverter Class | Conaito.PowerLight Namespace


PowerPointConverter.SlideProcessedHandler Delegate

Slide processed delegate

[Visual Basic]
Public Delegate Function SlideProcessedHandler( _
ByVal currentSlide As Integer, _
ByVal totalSlides As Integer _
)
[C#]
public delegate void SlideProcessedHandler(
int currentSlide,
int totalSlides
);

Requirements

Namespace: Conaito.PowerLight

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

Conaito.PowerLight Namespace


PresentationInfo Class

PresentationInfo class

For a list of all members of this type, see PresentationInfo Members .

System.Object
PresentationInfo

[Visual Basic]
Public Class PresentationInfo
[C#]
public class PresentationInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PowerLight

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

PresentationInfo Members | Conaito.PowerLight Namespace


PresentationInfo Members

PresentationInfo overview

Public Instance Constructors

PresentationInfo Constructor Initializes a new instance of the PresentationInfo class.

Public Instance Properties

Author | Gets or sets the author.
Height | Gets or sets the height.
SlidesCount | Gets or sets the slides count.
Title | Gets or sets the title.
Width | Gets or sets the width.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

PresentationInfo Class | Conaito.PowerLight Namespace


PresentationInfo Constructor

Initializes a new instance of the PresentationInfo class.

[Visual Basic]
Public Sub New()
[C#]
PresentationInfo();

See Also

PresentationInfo Class | Conaito.PowerLight Namespace


PresentationInfo Properties

The properties of the PresentationInfo class are listed below. For a complete list of PresentationInfo class members, see the PresentationInfo Members topic.

Public Instance Properties

Author | Gets or sets the author.
Height | Gets or sets the height.
SlidesCount | Gets or sets the slides count.
Title | Gets or sets the title.
Width | Gets or sets the width.

See Also

PresentationInfo Class | Conaito.PowerLight Namespace


Author Property

conaito Powerlight SDK 1.2

PresentationInfo.Author Property

Gets or sets the author.

[Visual Basic]
Public Property Author() As String
Public Get
End Get
Friend Set
End Set
End Property
[C#]
public string Author { public get; internal set; }

Property Value

The author.

See Also

PresentationInfo Class | Conaito.PowerLight Namespace


Height Property

conaito Powerlight SDK 1.2

PresentationInfo.Height Property

Gets or sets the height.

[Visual Basic]
Public Property Height() As Integer
Public Get
End Get
Friend Set
End Set
End Property
[C#]
public int Height { public get; internal set; }

Property Value

The height.

See Also

PresentationInfo Class | Conaito.PowerLight Namespace


SlidesCount Property

conaito Powerlight SDK 1.2

PresentationInfo.SlidesCount Property

Gets or sets the slides count.

[Visual Basic]
Public Property SlidesCount() As Integer
Public Get
End Get
Friend Set
End Set
End Property
[C#]
public int SlidesCount { public get; internal set; }

Property Value

The slides count.

See Also

PresentationInfo Class | Conaito.PowerLight Namespace


Title Property

conaito Powerlight SDK 1.2

PresentationInfo.Title Property

Gets or sets the title.

[Visual Basic]
Public Property Title() As String
Public Get
End Get
Friend Set
End Set
End Property
[C#]
public string Title { public get; internal set; }

Property Value

The title.

See Also

PresentationInfo Class | Conaito.PowerLight Namespace


Width Property

conaito Powerlight SDK 1.2

PresentationInfo.Width Property

Gets or sets the width.

[Visual Basic]
Public Property Width() As Integer
Public Get
End Get
Friend Set
End Set
End Property
[C#]
public int Width { public get; internal set; }

Property Value

The width.

See Also

PresentationInfo Class | Conaito.PowerLight Namespace


SlideTransition Enumeration

Slide transition type

[Visual Basic]
Public Enum SlideTransition
[C#]
public enum SlideTransition

Members

Member Name | Description
NoTransition |
CircleInTransition |
CircleOutTransition |
CrossFadeTransition |
SlideDownTransition |
SlideLeftTransition |
SlideRightTransition |
SlideUpTransition |
TranslateDownTransition |
TranslateLeftTransition |
TranslateRightTransition |
TranslateUpTransition |

Requirements

Namespace: Conaito.PowerLight

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

Conaito.PowerLight Namespace


TestEnvironmentResult Enumeration

[Visual Basic]
Public Enum TestEnvironmentResult
[C#]
public enum TestEnvironmentResult

Members

Member Name | Description
Success |
PowerPointNotInstalled |
PowerPointInteropNotAvailable |
OfficeInteropNotAvailable |

Requirements

Namespace: Conaito.PowerLight

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

Conaito.PowerLight Namespace


Conaito.PowerLight.Exceptions

conaito Powerlight SDK 1.2

Conaito.PowerLight.Exceptions Namespace

Namespace Hierarchy

Classes

Class | Description
ConvertionException | Exception on convertion process
LicenseException | License info exception
PowerPointNotInstalledException | Exception on convertion process
XPSPrinterNotExistsException | Exception on convertion process


ConvertionException Class

Exception on convertion process

For a list of all members of this type, see ConvertionException Members .

System.Object
Exception
ConvertionException

[Visual Basic]
<Serializable> _
Public Class ConvertionException
Inherits Exception
[C#]
[Serializable]
public class ConvertionException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PowerLight.Exceptions

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

ConvertionException Members | Conaito.PowerLight.Exceptions Namespace


ConvertionException Members

ConvertionException overview

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Constructors

ConvertionException Constructor Initializes a new instance of the ConvertionException class.

Protected Instance Properties

HResult (inherited from Exception)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ConvertionException Class | Conaito.PowerLight.Exceptions Namespace


ConvertionException Constructor

Initializes a new instance of the ConvertionException class.

[Visual Basic]
Protected Overloads Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
ConvertionException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception Type | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).

See Also

ConvertionException Class | Conaito.PowerLight.Exceptions Namespace


LicenseException Class

License info exception

For a list of all members of this type, see LicenseException Members .

System.Object
Exception
LicenseException

[Visual Basic]
<Serializable> _
Public Class LicenseException
Inherits Exception
[C#]
[Serializable]
public class LicenseException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PowerLight.Exceptions

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

LicenseException Members | Conaito.PowerLight.Exceptions Namespace


LicenseException Members

LicenseException overview

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Constructors

LicenseException Constructor Initializes a new instance of the LicenseException class.

Protected Instance Properties

HResult (inherited from Exception)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

LicenseException Class | Conaito.PowerLight.Exceptions Namespace


LicenseException Constructor

Initializes a new instance of the LicenseException class.

[Visual Basic]
Protected Overloads Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
LicenseException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception Type | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).

See Also

LicenseException Class | Conaito.PowerLight.Exceptions Namespace


PowerPointNotInstalledException Class

Exception on convertion process

For a list of all members of this type, see PowerPointNotInstalledException Members .

System.Object
Exception
PowerPointNotInstalledException

[Visual Basic]
<Serializable> _
Public Class PowerPointNotInstalledException
Inherits Exception
[C#]
[Serializable]
public class PowerPointNotInstalledException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PowerLight.Exceptions

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

PowerPointNotInstalledException Members | Conaito.PowerLight.Exceptions Namespace


PowerPointNotInstalledException Members

PowerPointNotInstalledException overview

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Constructors

PowerPointNotInstalledException Constructor Initializes a new instance of the PowerPointNotInstalledException class.

Protected Instance Properties

HResult (inherited from Exception)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

PowerPointNotInstalledException Class | Conaito.PowerLight.Exceptions Namespace


PowerPointNotInstalledException Constructor

Initializes a new instance of the PowerPointNotInstalledException class.

[Visual Basic]
Protected Overloads Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
PowerPointNotInstalledException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception Type | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).

See Also

PowerPointNotInstalledException Class | Conaito.PowerLight.Exceptions Namespace


XPSPrinterNotExistsException Class

Exception on convertion process

For a list of all members of this type, see XPSPrinterNotExistsException Members .

System.Object
Exception
XPSPrinterNotExistsException

[Visual Basic]
<Serializable> _
Public Class XPSPrinterNotExistsException
Inherits Exception
[C#]
[Serializable]
public class XPSPrinterNotExistsException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PowerLight.Exceptions

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

XPSPrinterNotExistsException Members | Conaito.PowerLight.Exceptions Namespace


XPSPrinterNotExistsException Members

XPSPrinterNotExistsException overview

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Constructors

XPSPrinterNotExistsException Constructor Initializes a new instance of the XPSPrinterNotExistsException class.

Protected Instance Properties

HResult (inherited from Exception)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

XPSPrinterNotExistsException Class | Conaito.PowerLight.Exceptions Namespace


XPSPrinterNotExistsException Constructor

Initializes a new instance of the XPSPrinterNotExistsException class.

[Visual Basic]
Protected Overloads Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
XPSPrinterNotExistsException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception Type | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).

See Also

XPSPrinterNotExistsException Class | Conaito.PowerLight.Exceptions Namespace


Conaito.PowerLight.XmlPlayer

conaito Powerlight SDK 1.2

Conaito.PowerLight.XmlPlayer Namespace

Namespace Hierarchy

Classes

Class | Description
XmlAlbum |
XmlData |
XmlSlide |
XmlSlideCollection |


XmlAlbum Class

For a list of all members of this type, see XmlAlbum Members .

System.Object
XmlAlbum

[Visual Basic]
<XmlType(AnonymousType:=False, IncludeInSchema:=True, TypeName:="properties", Namespace:="null")> _
Public Class XmlAlbum
[C#]
[XmlType(AnonymousType=False, IncludeInSchema=True, TypeName="properties", Namespace="null")]
public class XmlAlbum

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PowerLight.XmlPlayer

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

XmlAlbum Members | Conaito.PowerLight.XmlPlayer Namespace


XmlAlbum Members

XmlAlbum overview

Public Instance Constructors

XmlAlbum Constructor Initializes a new instance of the XmlAlbum class.

Public Instance Properties

Description
Slides
Source
Title

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

XmlAlbum Class | Conaito.PowerLight.XmlPlayer Namespace


XmlAlbum Constructor

Initializes a new instance of the XmlAlbum class.

[Visual Basic]
Public Sub New()
[C#]
XmlAlbum();

See Also

XmlAlbum Class | Conaito.PowerLight.XmlPlayer Namespace


XmlAlbum Properties

The properties of the XmlAlbum class are listed below. For a complete list of XmlAlbum class members, see the XmlAlbum Members topic.

Public Instance Properties

Description
Slides
Source
Title

See Also

XmlAlbum Class | Conaito.PowerLight.XmlPlayer Namespace


Description Property

conaito Powerlight SDK 1.2

XmlAlbum.Description Property

[Visual Basic]
<XmlAttribute(Type:=null, AttributeName:="description", Namespace:="null", Form:=XmlSchemaForm.None)> _
Public Property Description() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlAttribute(Type=null, AttributeName="description", Namespace="null", Form=XmlSchemaForm.None)]
public string Description { public get; public set; }

See Also

XmlAlbum Class | Conaito.PowerLight.XmlPlayer Namespace


Slides Property

conaito Powerlight SDK 1.2

XmlAlbum.Slides Property

[Visual Basic]
<XmlElement(Type:=null, ElementName:="slide", Namespace:="null", IsNullable:=False, Form:=XmlSchemaForm.None, Order:=-1)> _
Public Property Slides() As XmlSlideCollection
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlElement(Type=null, ElementName="slide", Namespace="null", IsNullable=False, Form=XmlSchemaForm.None, Order=-1)]
public XmlSlideCollection Slides { public get; public set; }

See Also

XmlAlbum Class | Conaito.PowerLight.XmlPlayer Namespace


Source Property

conaito Powerlight SDK 1.2

XmlAlbum.Source Property

[Visual Basic]
<XmlAttribute(Type:=null, AttributeName:="source", Namespace:="null", Form:=XmlSchemaForm.None)> _
Public Property Source() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlAttribute(Type=null, AttributeName="source", Namespace="null", Form=XmlSchemaForm.None)]
public string Source { public get; public set; }

See Also

XmlAlbum Class | Conaito.PowerLight.XmlPlayer Namespace


Title Property

conaito Powerlight SDK 1.2

XmlAlbum.Title Property

[Visual Basic]
<XmlAttribute(Type:=null, AttributeName:="title", Namespace:="null", Form:=XmlSchemaForm.None)> _
Public Property Title() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlAttribute(Type=null, AttributeName="title", Namespace="null", Form=XmlSchemaForm.None)]
public string Title { public get; public set; }

See Also

XmlAlbum Class | Conaito.PowerLight.XmlPlayer Namespace


XmlData Class

For a list of all members of this type, see XmlData Members .

System.Object
XmlData

[Visual Basic]
<XmlRoot(ElementName:="data", Namespace:="null", IsNullable:=True)> _
Public Class XmlData
[C#]
[XmlRoot(ElementName="data", Namespace="null", IsNullable=True)]
public class XmlData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PowerLight.XmlPlayer

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

XmlData Members | Conaito.PowerLight.XmlPlayer Namespace


XmlData Members

XmlData overview

Public Instance Constructors

XmlData Constructor Initializes a new instance of the XmlData class.

Public Instance Properties

Album
Transition

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

XmlData Class | Conaito.PowerLight.XmlPlayer Namespace


XmlData Constructor

Initializes a new instance of the XmlData class.

[Visual Basic]
Public Sub New()
[C#]
XmlData();

See Also

XmlData Class | Conaito.PowerLight.XmlPlayer Namespace


XmlData Properties

The properties of the XmlData class are listed below. For a complete list of XmlData class members, see the XmlData Members topic.

Public Instance Properties

Album
Transition

See Also

XmlData Class | Conaito.PowerLight.XmlPlayer Namespace


Album Property

conaito Powerlight SDK 1.2

XmlData.Album Property

[Visual Basic]
<XmlElement(Type:=null, ElementName:="album", Namespace:="null", IsNullable:=False, Form:=XmlSchemaForm.None, Order:=-1)> _
Public Property Album() As XmlAlbum
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlElement(Type=null, ElementName="album", Namespace="null", IsNullable=False, Form=XmlSchemaForm.None, Order=-1)]
public XmlAlbum Album { public get; public set; }

See Also

XmlData Class | Conaito.PowerLight.XmlPlayer Namespace


Transition Property

conaito Powerlight SDK 1.2

XmlData.Transition Property

[Visual Basic]
<XmlAttribute(Type:=null, AttributeName:="transition", Namespace:="null", Form:=XmlSchemaForm.None)> _
Public Property Transition() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlAttribute(Type=null, AttributeName="transition", Namespace="null", Form=XmlSchemaForm.None)]
public string Transition { public get; public set; }

See Also

XmlData Class | Conaito.PowerLight.XmlPlayer Namespace


XmlSlide Class

For a list of all members of this type, see XmlSlide Members .

System.Object
XmlSlide

[Visual Basic]
<XmlType(TypeName:="slide", AnonymousType:=False, IncludeInSchema:=True, Namespace:="null")> _
Public Class XmlSlide
[C#]
[XmlType(TypeName="slide", AnonymousType=False, IncludeInSchema=True, Namespace="null")]
public class XmlSlide

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PowerLight.XmlPlayer

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

XmlSlide Members | Conaito.PowerLight.XmlPlayer Namespace


XmlSlide Members

XmlSlide overview

Public Instance Constructors

XmlSlide Constructor Initializes a new instance of the XmlSlide class.

Public Instance Properties

Description
Source
Thumbnail
Title

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

XmlSlide Class | Conaito.PowerLight.XmlPlayer Namespace


XmlSlide Constructor

Initializes a new instance of the XmlSlide class.

[Visual Basic]
Public Sub New()
[C#]
XmlSlide();

See Also

XmlSlide Class | Conaito.PowerLight.XmlPlayer Namespace


XmlSlide Properties

The properties of the XmlSlide class are listed below. For a complete list of XmlSlide class members, see the XmlSlide Members topic.

Public Instance Properties

Description
Source
Thumbnail
Title

See Also

XmlSlide Class | Conaito.PowerLight.XmlPlayer Namespace


Description Property

conaito Powerlight SDK 1.2

XmlSlide.Description Property

[Visual Basic]
<XmlAttribute(Type:=null, AttributeName:="description", Namespace:="null", Form:=XmlSchemaForm.None)> _
Public Property Description() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlAttribute(Type=null, AttributeName="description", Namespace="null", Form=XmlSchemaForm.None)]
public string Description { public get; public set; }

See Also

XmlSlide Class | Conaito.PowerLight.XmlPlayer Namespace


Source Property

conaito Powerlight SDK 1.2

XmlSlide.Source Property

[Visual Basic]
<XmlAttribute(Type:=null, AttributeName:="source", Namespace:="null", Form:=XmlSchemaForm.None)> _
Public Property Source() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlAttribute(Type=null, AttributeName="source", Namespace="null", Form=XmlSchemaForm.None)]
public string Source { public get; public set; }

See Also

XmlSlide Class | Conaito.PowerLight.XmlPlayer Namespace


Thumbnail Property

conaito Powerlight SDK 1.2

XmlSlide.Thumbnail Property

[Visual Basic]
<XmlAttribute(Type:=null, AttributeName:="thumbnail", Namespace:="null", Form:=XmlSchemaForm.None)> _
Public Property Thumbnail() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlAttribute(Type=null, AttributeName="thumbnail", Namespace="null", Form=XmlSchemaForm.None)]
public string Thumbnail { public get; public set; }

See Also

XmlSlide Class | Conaito.PowerLight.XmlPlayer Namespace


Title Property

conaito Powerlight SDK 1.2

XmlSlide.Title Property

[Visual Basic]
<XmlAttribute(Type:=null, AttributeName:="title", Namespace:="null", Form:=XmlSchemaForm.None)> _
Public Property Title() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlAttribute(Type=null, AttributeName="title", Namespace="null", Form=XmlSchemaForm.None)]
public string Title { public get; public set; }

See Also

XmlSlide Class | Conaito.PowerLight.XmlPlayer Namespace


XmlSlideCollection Class

For a list of all members of this type, see XmlSlideCollection Members .

System.Object
CollectionBase
XmlSlideCollection

[Visual Basic]
<DefaultMember(MemberName:="Item")> _
Public Class XmlSlideCollection
Inherits CollectionBase
[C#]
[DefaultMember(MemberName="Item")]
public class XmlSlideCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PowerLight.XmlPlayer

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

XmlSlideCollection Members | Conaito.PowerLight.XmlPlayer Namespace


XmlSlideCollection Members

XmlSlideCollection overview

Public Instance Constructors

XmlSlideCollection Constructor Initializes a new instance of the XmlSlideCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase)
Count (inherited from CollectionBase)
Item

Public Instance Methods

Add
Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

Protected Instance Properties

InnerList (inherited from CollectionBase)
List (inherited from CollectionBase)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
OnClear (inherited from CollectionBase)
OnClearComplete (inherited from CollectionBase)
OnInsert (inherited from CollectionBase)
OnInsertComplete (inherited from CollectionBase)
OnRemove (inherited from CollectionBase)
OnRemoveComplete (inherited from CollectionBase)
OnSet (inherited from CollectionBase)
OnSetComplete (inherited from CollectionBase)
OnValidate (inherited from CollectionBase)

See Also

XmlSlideCollection Class | Conaito.PowerLight.XmlPlayer Namespace


XmlSlideCollection Constructor

Initializes a new instance of the XmlSlideCollection class.

[Visual Basic]
Public Sub New()
[C#]
XmlSlideCollection();

See Also

XmlSlideCollection Class | Conaito.PowerLight.XmlPlayer Namespace


XmlSlideCollection Properties

The properties of the XmlSlideCollection class are listed below. For a complete list of XmlSlideCollection class members, see the XmlSlideCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase)
Count (inherited from CollectionBase)
Item

Protected Instance Properties

InnerList (inherited from CollectionBase)
List (inherited from CollectionBase)

See Also

XmlSlideCollection Class | Conaito.PowerLight.XmlPlayer Namespace


Item Property

conaito Powerlight SDK 1.2

XmlSlideCollection.Item Property

[Visual Basic]
<XmlArrayItem(Type:=null, ElementName:="slide", Namespace:="null", NestingLevel:=0, IsNullable:=False, Form:=XmlSchemaForm.None)> _
Public Property Item( _
ByVal index As Integer _
) As XmlSlide
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlArrayItem(Type=null, ElementName="slide", Namespace="null", NestingLevel=0, IsNullable=False, Form=XmlSchemaForm.None)]
public XmlSlide this[
int index
] { public get; public set; }

See Also

XmlSlideCollection Class | Conaito.PowerLight.XmlPlayer Namespace


XmlSlideCollection Methods

The methods of the XmlSlideCollection class are listed below. For a complete list of XmlSlideCollection class members, see the XmlSlideCollection Members topic.

Public Instance Methods

Add
Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
OnClear (inherited from CollectionBase)
OnClearComplete (inherited from CollectionBase)
OnInsert (inherited from CollectionBase)
OnInsertComplete (inherited from CollectionBase)
OnRemove (inherited from CollectionBase)
OnRemoveComplete (inherited from CollectionBase)
OnSet (inherited from CollectionBase)
OnSetComplete (inherited from CollectionBase)
OnValidate (inherited from CollectionBase)

See Also

XmlSlideCollection Class | Conaito.PowerLight.XmlPlayer Namespace


XmlSlideCollection.Add Method

[Visual Basic]
Public Sub Add( _
ByVal xmlSlide As XmlSlide _
)
[C#]
public int Add(
XmlSlide xmlSlide
);

See Also

XmlSlideCollection Class | Conaito.PowerLight.XmlPlayer Namespace


Conaito.PowerLight.ZipCore

conaito Powerlight SDK 1.2

Conaito.PowerLight.ZipCore Namespace

Namespace Hierarchy

Interfaces

Interface | Description
IScanFilter | Scanning filters support filtering of names.

Enumerations

Enumeration | Description
FileUpdateMode | The possible ways of CommitUpdate to an archive.


FileUpdateMode Enumeration

The possible ways of CommitUpdate to an archive.

[Visual Basic]
Public Enum FileUpdateMode
[C#]
public enum FileUpdateMode

Members

Member Name | Description
Safe | Perform all updates on temporary files ensuring that the original file is saved.
Direct | Update the archive directly, which is faster but less safe.

Requirements

Namespace: Conaito.PowerLight.ZipCore

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

Conaito.PowerLight.ZipCore Namespace


IScanFilter Interface

Scanning filters support filtering of names.

For a list of all members of this type, see IScanFilter Members .

[Visual Basic]
Public Interface IScanFilter
[C#]
public interface IScanFilter

Requirements

Namespace: Conaito.PowerLight.ZipCore

Assembly: Conaito.PowerLight (in Conaito.PowerLight.dll)

See Also

IScanFilter Members | Conaito.PowerLight.ZipCore Namespace


IScanFilter Members

IScanFilter overview

Public Instance Methods

IsMatch Test a name to see if it 'matches' the filter.

See Also

IScanFilter Interface | Conaito.PowerLight.ZipCore Namespace


IScanFilter Methods

The methods of the IScanFilter interface are listed below. For a complete list of IScanFilter interface members, see the IScanFilter Members topic.

Public Instance Methods

IsMatch Test a name to see if it 'matches' the filter.

See Also

IScanFilter Interface | Conaito.PowerLight.ZipCore Namespace


IScanFilter.IsMatch Method

Test a name to see if it 'matches' the filter.

[Visual Basic]
Public Sub IsMatch( _
ByVal name As String _
)
[C#]
bool IsMatch(
string name
);

Parameters

name
The name to test.

Return Value

Returns true if the name matches the filter, false if it does not match.

See Also

IScanFilter Interface | Conaito.PowerLight.ZipCore Namespace


Conaito.PowerLight.ExceptionsHierarchy

conaito Powerlight SDK 1.2

Conaito.PowerLight.Exceptions Hierarchy

Object
Exception ---- ISerializable
ConvertionException
LicenseException
PowerPointNotInstalledException
XPSPrinterNotExistsException

See Also

Conaito.PowerLight.Exceptions Namespace


Conaito.PowerLight.XmlPlayerHierarchy

conaito Powerlight SDK 1.2

Conaito.PowerLight.XmlPlayer Hierarchy

Object
XmlAlbum
XmlData
XmlSlide
CollectionBase ---- ICollection, IEnumerable, IList
XmlSlideCollection

See Also

Conaito.PowerLight.XmlPlayer Namespace


Conaito.PowerLight.ZipCoreHierarchy

conaito Powerlight SDK 1.2

Conaito.PowerLight.ZipCore Hierarchy

Object
IScanFilter
ValueType
Enum ---- IComparable, IConvertible, IFormattable
FileUpdateMode

See Also

Conaito.PowerLight.ZipCore Namespace


Conaito.PowerLightHierarchy

conaito Powerlight SDK 1.2

Conaito.PowerLight Hierarchy

Object
ConvertingSettings
DocumentInfo
LicenseInfo
PowerPointConverter
PresentationInfo
Delegate ---- ICloneable, ISerializable
MulticastDelegate
PowerPointConverter.SlideProcessedHandler
ValueType
Enum ---- IComparable, IConvertible, IFormattable
ImageFormat
ImageQuality
ImageStretch
LicenseMode
SlideTransition
TestEnvironmentResult

See Also

Conaito.PowerLight Namespace