Conaito.PPT2HTML5 Namespace

Conaito.PPT2HTML5 Namespace Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Classes
 | Class | Description
Public class | ConversionFinishResult | ConversionFinishResult class
Public class | EnvironmentInfo | EnvironmentInfo class
Public class | MediaSettings | MediaSettings class represents media format and compression settings
Public class | OperationResult | OperationResult base class
Public class | PresentationConverter | The PresentationConverter class it a main class of Conaito PowerPoint2Html5 SDK. It provides methods and properties to convert PowerPoint presentations to HTML 5 To start work with SDK creates an instance of the PresentationConverter.
Public class | PresentationInfo | PresentationInfo class
Public class | PresentationOpenedResult | PresentationOpenedResult class
Public class | Settings | ConverterSettings class
Public class | ThumbsGeneratedResult | ThumbsGeneratedResult class
Delegates
 | Delegate | Description
Public delegate | OnAudioConversionFinish | OnAudioConversionFinish delegate
Public delegate | OnAudioConversionStart | OnAudioConversionFinish delegate
Public delegate | OnConversionFinishDelegate | OnConversionFinishDelegate
Public delegate | OnPresentationOpenedDelegate | OnPresentationOpenedDelegate
Public delegate | OnShapeProcessDelegate | OnShapeProcessDelegate
Public delegate | OnSlideProcessDelegate | OnSlideProcessDelegate
Public delegate | OnThumbItemProcessDelegate | OnThumbItemProcessDelegate
Public delegate | OnThumbsGeneratedDelegate | OnThumbsGeneratedDelegate
Public delegate | OnVideoConversionFinish | OnVideoConversionFinish delegate
Public delegate | OnVideoConversionStart | OnVideoConversionStart delegate
Enumerations
 | Enumeration | Description
Public enumeration | AudioFormat | Represents HTML 5 audio format enumeration
Public enumeration | ImageFormat | ImageFormat class
Public enumeration | OutputType | Specifies the output range of the html document.
Public enumeration | PowerPointVersion | PowerPoint version enumeration
Public enumeration | VideoFormat | Represents HTML 5 video format enumeration

Conaito PowerPoint-to-HTML5 SDK

Send Feedback on this topic to feedback@conaito.com.


AudioFormat Enumeration

AudioFormat Enumeration Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Represents HTML 5 audio format enumeration

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum AudioFormat
public enum AudioFormat
Public Enumeration AudioFormat
Public Enumeration AudioFormat
public enum class AudioFormat
public enum class AudioFormat
Members
Member name | Value | Description
MP3 | 0 | The MP3 audio format, supported in IE 9+, Chrome 6+, Safari 4+
OggVorbis | 1 | The Ogg Vorbis audio format, supported in Chrome 6+, Opera 10.6+, Firefox 3.6+
See Also
Conaito.PPT2HTML5 Namespace


ConversionFinishResult Class

ConversionFinishResult Class Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
ConversionFinishResult class
Inheritance Hierarchy
Online System Object
Conaito.PPT2HTML5 OperationResult
Conaito.PPT2HTML5 ConversionFinishResult

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ConversionFinishResult : OperationResult
[SerializableAttribute]
public class ConversionFinishResult : OperationResult
<SerializableAttribute>
Public Class ConversionFinishResult
    Inherits OperationResult
<SerializableAttribute>
Public Class ConversionFinishResult
    Inherits OperationResult
[SerializableAttribute]
public ref class ConversionFinishResult : public OperationResult
[SerializableAttribute]
public ref class ConversionFinishResult : public OperationResult
See Also
ConversionFinishResult Members


ConversionFinishResult Members

ConversionFinishResult Members Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK

The ConversionFinishResult type exposes the following members.
Properties
 | Name | Description
Public property | HtmlPath | Gets the HTML path.
Back to Top
See Also
ConversionFinishResult Class


ConversionFinishResult Properties

ConversionFinishResult Properties Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDKThe ConversionFinishResult type exposes the following members.
Properties
 | Name | Description
Public property | HtmlPath | Gets the HTML path.
Back to Top
See Also
ConversionFinishResult Class


ConversionFinishResult.HtmlPath Property

ConversionFinishResult HtmlPath Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets the HTML path.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string HtmlPath { get; internal set; }
public string HtmlPath { get; internal set; }
Public Property HtmlPath As String
    Get
    Friend Set
Public Property HtmlPath As String
    Get
    Friend Set
public:
property String^ HtmlPath {
    String^ get ();
    internal: void set (String^ value);
}
public:
property String^ HtmlPath {
    String^ get ();
    internal: void set (String^ value);
}
Property Value
Type:   Online String

            The HTML path.

See Also
ConversionFinishResult Class
ConversionFinishResult Members


EnvironmentInfo Class

EnvironmentInfo Class Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
EnvironmentInfo class
Inheritance Hierarchy
Online System Object
Conaito.PPT2HTML5 EnvironmentInfo

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class EnvironmentInfo
[SerializableAttribute]
public class EnvironmentInfo
<SerializableAttribute>
Public Class EnvironmentInfo
<SerializableAttribute>
Public Class EnvironmentInfo
[SerializableAttribute]
public ref class EnvironmentInfo
[SerializableAttribute]
public ref class EnvironmentInfo
See Also
EnvironmentInfo Members


EnvironmentInfo Members

EnvironmentInfo Members Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK

The EnvironmentInfo type exposes the following members.
Properties
 | Name | Description
Public property | IsPowerPointInstalled | Gets a value indicating whether this instance is power point installed.
Public property | PowerPointVersion | Gets the power point installed path.
Public property | ReadyToConvertion | Gets a value indicating whether [ready to convertion].
Back to Top
See Also
EnvironmentInfo Class


EnvironmentInfo Properties

EnvironmentInfo Properties Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDKThe EnvironmentInfo type exposes the following members.
Properties
 | Name | Description
Public property | IsPowerPointInstalled | Gets a value indicating whether this instance is power point installed.
Public property | PowerPointVersion | Gets the power point installed path.
Public property | ReadyToConvertion | Gets a value indicating whether [ready to convertion].
Back to Top
See Also
EnvironmentInfo Class


EnvironmentInfo.IsPowerPointInstalled Property

EnvironmentInfo IsPowerPointInstalled Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets a value indicating whether this instance is power point installed.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsPowerPointInstalled { get; private set; }
public bool IsPowerPointInstalled { get; private set; }
Public Property IsPowerPointInstalled As Boolean
    Get
    Private Set
Public Property IsPowerPointInstalled As Boolean
    Get
    Private Set
public:
property bool IsPowerPointInstalled {
    bool get ();
    private: void set (bool value);
}
public:
property bool IsPowerPointInstalled {
    bool get ();
    private: void set (bool value);
}
Property Value
Type:   Online Boolean
true if this instance is power point installed; otherwise, false.

See Also
EnvironmentInfo Class
EnvironmentInfo Members


EnvironmentInfo.PowerPointVersion Property

EnvironmentInfo PowerPointVersion Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets the power point installed path.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Nullable<PowerPointVersion> PowerPointVersion { get; private set; }
public Nullable<PowerPointVersion> PowerPointVersion { get; private set; }
Public Property PowerPointVersion As Nullable(Of PowerPointVersion)
    Get
    Private Set
Public Property PowerPointVersion As Nullable(Of PowerPointVersion)
    Get
    Private Set
public:
property Nullable<PowerPointVersion> PowerPointVersion {
    Nullable<PowerPointVersion> get ();
    private: void set (Nullable<PowerPointVersion> value);
}
public:
property Nullable<PowerPointVersion> PowerPointVersion {
    Nullable<PowerPointVersion> get ();
    private: void set (Nullable<PowerPointVersion> value);
}
Property Value
Type:   Online Nullable  PowerPointVersion

            The power point installed path.

See Also
EnvironmentInfo Class
EnvironmentInfo Members


EnvironmentInfo.ReadyToConvertion Property

EnvironmentInfo ReadyToConvertion Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets a value indicating whether [ready to convertion].

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ReadyToConvertion { get; }
public bool ReadyToConvertion { get; }
Public ReadOnly Property ReadyToConvertion As Boolean
    Get
Public ReadOnly Property ReadyToConvertion As Boolean
    Get
public:
property bool ReadyToConvertion {
    bool get ();
}
public:
property bool ReadyToConvertion {
    bool get ();
}
Property Value
Type:   Online Boolean
true if [ready to convertion]; otherwise, false.

See Also
EnvironmentInfo Class
EnvironmentInfo Members


ImageFormat Enumeration

ImageFormat Enumeration Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
ImageFormat class

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ImageFormat
public enum ImageFormat
Public Enumeration ImageFormat
Public Enumeration ImageFormat
public enum class ImageFormat
public enum class ImageFormat
Members
Member name | Value | Description
Png | 0 | The PNG format
Jpg | 1 | The JPG format
Bmp | 2 | The BMP format
See Also


MediaSettings Class

MediaSettings Class Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
MediaSettings class represents media format and compression settings
Inheritance Hierarchy
Online System Object
Conaito.PPT2HTML5 MediaSettings

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class MediaSettings
public sealed class MediaSettings
Public NotInheritable Class MediaSettings
Public NotInheritable Class MediaSettings
public ref class MediaSettings sealed
public ref class MediaSettings sealed
See Also
MediaSettings Members


MediaSettings Members

MediaSettings Members Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK

The MediaSettings type exposes the following members.
Properties
 | Name | Description
Public property | ExportAudioToMP3 | Gets or sets a value indicating whether [export audio as MP3].
Public property | ExportAudioToOgg | Gets or sets a value indicating whether [export audio as ogg].
Public property | ExportVideoToMP4 | Gets or sets a value indicating whether [export video as MP4].
Public property | ExportVideoToOgg | Gets or sets a value indicating whether [export video as ogg].
Public property | ExportVideoToWebM | Gets or sets a value indicating whether [export video as WebM].
Back to Top
See Also
MediaSettings Class


MediaSettings Properties

MediaSettings Properties Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDKThe MediaSettings type exposes the following members.
Properties
 | Name | Description
Public property | ExportAudioToMP3 | Gets or sets a value indicating whether [export audio as MP3].
Public property | ExportAudioToOgg | Gets or sets a value indicating whether [export audio as ogg].
Public property | ExportVideoToMP4 | Gets or sets a value indicating whether [export video as MP4].
Public property | ExportVideoToOgg | Gets or sets a value indicating whether [export video as ogg].
Public property | ExportVideoToWebM | Gets or sets a value indicating whether [export video as WebM].
Back to Top
See Also
MediaSettings Class


MediaSettings.ExportAudioToMP3 Property

MediaSettings ExportAudioToMP3 Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets or sets a value indicating whether [export audio as MP3].

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExportAudioToMP3 { get; set; }
public bool ExportAudioToMP3 { get; set; }
Public Property ExportAudioToMP3 As Boolean
    Get
    Set
Public Property ExportAudioToMP3 As Boolean
    Get
    Set
public:
property bool ExportAudioToMP3 {
    bool get ();
    void set (bool value);
}
public:
property bool ExportAudioToMP3 {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
true if [export audio as M p3]; otherwise, false.

See Also
MediaSettings Class
MediaSettings Members


MediaSettings.ExportAudioToOgg Property

MediaSettings ExportAudioToOgg Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets or sets a value indicating whether [export audio as ogg].

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExportAudioToOgg { get; set; }
public bool ExportAudioToOgg { get; set; }
Public Property ExportAudioToOgg As Boolean
    Get
    Set
Public Property ExportAudioToOgg As Boolean
    Get
    Set
public:
property bool ExportAudioToOgg {
    bool get ();
    void set (bool value);
}
public:
property bool ExportAudioToOgg {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
true if [export audio as ogg]; otherwise, false.

See Also
MediaSettings Class
MediaSettings Members


MediaSettings.ExportVideoToMP4 Property

MediaSettings ExportVideoToMP4 Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets or sets a value indicating whether [export video as MP4].

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExportVideoToMP4 { get; set; }
public bool ExportVideoToMP4 { get; set; }
Public Property ExportVideoToMP4 As Boolean
    Get
    Set
Public Property ExportVideoToMP4 As Boolean
    Get
    Set
public:
property bool ExportVideoToMP4 {
    bool get ();
    void set (bool value);
}
public:
property bool ExportVideoToMP4 {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
true if [export video as M p4]; otherwise, false.

See Also
MediaSettings Class
MediaSettings Members


MediaSettings.ExportVideoToOgg Property

MediaSettings ExportVideoToOgg Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets or sets a value indicating whether [export video as ogg].

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExportVideoToOgg { get; set; }
public bool ExportVideoToOgg { get; set; }
Public Property ExportVideoToOgg As Boolean
    Get
    Set
Public Property ExportVideoToOgg As Boolean
    Get
    Set
public:
property bool ExportVideoToOgg {
    bool get ();
    void set (bool value);
}
public:
property bool ExportVideoToOgg {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
true if [export video as ogg]; otherwise, false.

See Also
MediaSettings Class
MediaSettings Members


MediaSettings.ExportVideoToWebM Property

MediaSettings ExportVideoToWebM Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets or sets a value indicating whether [export video as WebM].

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExportVideoToWebM { get; set; }
public bool ExportVideoToWebM { get; set; }
Public Property ExportVideoToWebM As Boolean
    Get
    Set
Public Property ExportVideoToWebM As Boolean
    Get
    Set
public:
property bool ExportVideoToWebM {
    bool get ();
    void set (bool value);
}
public:
property bool ExportVideoToWebM {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
true if [export video as SWF]; otherwise, false.

See Also
MediaSettings Class
MediaSettings Members


OnAudioConversionFinish Delegate

OnAudioConversionFinish Delegate Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
OnAudioConversionFinish delegate

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void OnAudioConversionFinish(
    AudioFormat audioFormat
)
public delegate void OnAudioConversionFinish(
    AudioFormat audioFormat
)
Public Delegate Sub OnAudioConversionFinish (
    audioFormat As AudioFormat
)
Public Delegate Sub OnAudioConversionFinish (
    audioFormat As AudioFormat
)
public delegate void OnAudioConversionFinish(
    AudioFormat audioFormat
)
public delegate void OnAudioConversionFinish(
    AudioFormat audioFormat
)
Parameters
audioFormat
Type: Conaito.PPT2HTML5 AudioFormat
The audio format.
See Also


OnAudioConversionStart Delegate

OnAudioConversionStart Delegate Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
OnAudioConversionFinish delegate

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void OnAudioConversionStart(
    AudioFormat audioFormat
)
public delegate void OnAudioConversionStart(
    AudioFormat audioFormat
)
Public Delegate Sub OnAudioConversionStart (
    audioFormat As AudioFormat
)
Public Delegate Sub OnAudioConversionStart (
    audioFormat As AudioFormat
)
public delegate void OnAudioConversionStart(
    AudioFormat audioFormat
)
public delegate void OnAudioConversionStart(
    AudioFormat audioFormat
)
Parameters
audioFormat
Type: Conaito.PPT2HTML5 AudioFormat
The audio format.
See Also


OnConversionFinishDelegate Delegate

OnConversionFinishDelegate Delegate Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
OnConversionFinishDelegate

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void OnConversionFinishDelegate(
    ConversionFinishResult result
)
public delegate void OnConversionFinishDelegate(
    ConversionFinishResult result
)
Public Delegate Sub OnConversionFinishDelegate (
    result As ConversionFinishResult
)
Public Delegate Sub OnConversionFinishDelegate (
    result As ConversionFinishResult
)
public delegate void OnConversionFinishDelegate(
    ConversionFinishResult^ result
)
public delegate void OnConversionFinishDelegate(
    ConversionFinishResult^ result
)
Parameters
result
Type: Conaito.PPT2HTML5 ConversionFinishResult
The result.
See Also


OnPresentationOpenedDelegate Delegate

OnPresentationOpenedDelegate Delegate Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
OnPresentationOpenedDelegate

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void OnPresentationOpenedDelegate(
    PresentationOpenedResult result
)
public delegate void OnPresentationOpenedDelegate(
    PresentationOpenedResult result
)
Public Delegate Sub OnPresentationOpenedDelegate (
    result As PresentationOpenedResult
)
Public Delegate Sub OnPresentationOpenedDelegate (
    result As PresentationOpenedResult
)
public delegate void OnPresentationOpenedDelegate(
    PresentationOpenedResult^ result
)
public delegate void OnPresentationOpenedDelegate(
    PresentationOpenedResult^ result
)
Parameters
result
Type: Conaito.PPT2HTML5 PresentationOpenedResult
The result.
See Also


OnShapeProcessDelegate Delegate

OnShapeProcessDelegate Delegate Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
OnShapeProcessDelegate

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void OnShapeProcessDelegate(
    int shapeIndex,
    int shapesCount
)
public delegate void OnShapeProcessDelegate(
    int shapeIndex,
    int shapesCount
)
Public Delegate Sub OnShapeProcessDelegate (
    shapeIndex As Integer,
    shapesCount As Integer
)
Public Delegate Sub OnShapeProcessDelegate (
    shapeIndex As Integer,
    shapesCount As Integer
)
public delegate void OnShapeProcessDelegate(
    int shapeIndex,
    int shapesCount
)
public delegate void OnShapeProcessDelegate(
    int shapeIndex,
    int shapesCount
)
Parameters
shapeIndex
Type:   Online System Int32
Index of the shape.
shapesCount
Type:   Online System Int32
The shapes count.
See Also


OnSlideProcessDelegate Delegate

OnSlideProcessDelegate Delegate Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
OnSlideProcessDelegate

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void OnSlideProcessDelegate(
    int slideIndex,
    int slideCount
)
public delegate void OnSlideProcessDelegate(
    int slideIndex,
    int slideCount
)
Public Delegate Sub OnSlideProcessDelegate (
    slideIndex As Integer,
    slideCount As Integer
)
Public Delegate Sub OnSlideProcessDelegate (
    slideIndex As Integer,
    slideCount As Integer
)
public delegate void OnSlideProcessDelegate(
    int slideIndex,
    int slideCount
)
public delegate void OnSlideProcessDelegate(
    int slideIndex,
    int slideCount
)
Parameters
slideIndex
Type:   Online System Int32
Index of the slide.
slideCount
Type:   Online System Int32
The slide count.
See Also


OnThumbItemProcessDelegate Delegate

OnThumbItemProcessDelegate Delegate Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
OnThumbItemProcessDelegate

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void OnThumbItemProcessDelegate(
    int thumbIndex,
    int thumbsCount,
    string thumbImagePath
)
public delegate void OnThumbItemProcessDelegate(
    int thumbIndex,
    int thumbsCount,
    string thumbImagePath
)
Public Delegate Sub OnThumbItemProcessDelegate (
    thumbIndex As Integer,
    thumbsCount As Integer,
    thumbImagePath As String
)
Public Delegate Sub OnThumbItemProcessDelegate (
    thumbIndex As Integer,
    thumbsCount As Integer,
    thumbImagePath As String
)
public delegate void OnThumbItemProcessDelegate(
    int thumbIndex,
    int thumbsCount,
    String^ thumbImagePath
)
public delegate void OnThumbItemProcessDelegate(
    int thumbIndex,
    int thumbsCount,
    String^ thumbImagePath
)
Parameters
thumbIndex
Type:   Online System Int32
Index of the thumb.
thumbsCount
Type:   Online System Int32
The thumbs count.
thumbImagePath
Type:   Online System String
The thumb image path.
See Also


OnThumbsGeneratedDelegate Delegate

OnThumbsGeneratedDelegate Delegate Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
OnThumbsGeneratedDelegate

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void OnThumbsGeneratedDelegate(
    ThumbsGeneratedResult result
)
public delegate void OnThumbsGeneratedDelegate(
    ThumbsGeneratedResult result
)
Public Delegate Sub OnThumbsGeneratedDelegate (
    result As ThumbsGeneratedResult
)
Public Delegate Sub OnThumbsGeneratedDelegate (
    result As ThumbsGeneratedResult
)
public delegate void OnThumbsGeneratedDelegate(
    ThumbsGeneratedResult^ result
)
public delegate void OnThumbsGeneratedDelegate(
    ThumbsGeneratedResult^ result
)
Parameters
result
Type: Conaito.PPT2HTML5 ThumbsGeneratedResult
The result.
See Also


OnVideoConversionFinish Delegate

OnVideoConversionFinish Delegate Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
OnVideoConversionFinish delegate

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void OnVideoConversionFinish(
    VideoFormat videoFormat
)
public delegate void OnVideoConversionFinish(
    VideoFormat videoFormat
)
Public Delegate Sub OnVideoConversionFinish (
    videoFormat As VideoFormat
)
Public Delegate Sub OnVideoConversionFinish (
    videoFormat As VideoFormat
)
public delegate void OnVideoConversionFinish(
    VideoFormat videoFormat
)
public delegate void OnVideoConversionFinish(
    VideoFormat videoFormat
)
Parameters
videoFormat
Type: Conaito.PPT2HTML5 VideoFormat
The video format.
See Also


OnVideoConversionStart Delegate

OnVideoConversionStart Delegate Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
OnVideoConversionStart delegate

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public delegate void OnVideoConversionStart(
    VideoFormat videoFormat
)
public delegate void OnVideoConversionStart(
    VideoFormat videoFormat
)
Public Delegate Sub OnVideoConversionStart (
    videoFormat As VideoFormat
)
Public Delegate Sub OnVideoConversionStart (
    videoFormat As VideoFormat
)
public delegate void OnVideoConversionStart(
    VideoFormat videoFormat
)
public delegate void OnVideoConversionStart(
    VideoFormat videoFormat
)
Parameters
videoFormat
Type: Conaito.PPT2HTML5 VideoFormat
The video format.
See Also


OperationResult Class

OperationResult Class Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
OperationResult base class
Inheritance Hierarchy
Online System Object
Conaito.PPT2HTML5 OperationResult
Conaito.PPT2HTML5 ConversionFinishResult
Conaito.PPT2HTML5 PresentationOpenedResult
Conaito.PPT2HTML5 ThumbsGeneratedResult

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public abstract class OperationResult
[SerializableAttribute]
public abstract class OperationResult
<SerializableAttribute>
Public MustInherit Class OperationResult
<SerializableAttribute>
Public MustInherit Class OperationResult
[SerializableAttribute]
public ref class OperationResult abstract
[SerializableAttribute]
public ref class OperationResult abstract
See Also
OperationResult Members


OperationResult Members

OperationResult Members Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK

The OperationResult type exposes the following members.
Properties
 | Name | Description
Public property | ErrorMessage | Gets the error message.
Public property | IsErrorReturned | Gets a value indicating whether this instance is error returned.
Back to Top
See Also
OperationResult Class


OperationResult Properties

OperationResult Properties Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDKThe OperationResult type exposes the following members.
Properties
 | Name | Description
Public property | ErrorMessage | Gets the error message.
Public property | IsErrorReturned | Gets a value indicating whether this instance is error returned.
Back to Top
See Also
OperationResult Class


OperationResult.ErrorMessage Property

OperationResult ErrorMessage Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets the error message.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ErrorMessage { get; internal set; }
public string ErrorMessage { get; internal set; }
Public Property ErrorMessage As String
    Get
    Friend Set
Public Property ErrorMessage As String
    Get
    Friend Set
public:
property String^ ErrorMessage {
    String^ get ();
    internal: void set (String^ value);
}
public:
property String^ ErrorMessage {
    String^ get ();
    internal: void set (String^ value);
}
Property Value
Type:   Online String

            The error message.

See Also
OperationResult Class
OperationResult Members


OperationResult.IsErrorReturned Property

OperationResult IsErrorReturned Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets a value indicating whether this instance is error returned.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsErrorReturned { get; internal set; }
public bool IsErrorReturned { get; internal set; }
Public Property IsErrorReturned As Boolean
    Get
    Friend Set
Public Property IsErrorReturned As Boolean
    Get
    Friend Set
public:
property bool IsErrorReturned {
    bool get ();
    internal: void set (bool value);
}
public:
property bool IsErrorReturned {
    bool get ();
    internal: void set (bool value);
}
Property Value
Type:   Online Boolean
true if this instance is error returned; otherwise, false.

See Also
OperationResult Class
OperationResult Members


OutputType Enumeration

OutputType Enumeration Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Specifies the output range of the html document.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum OutputType
public enum OutputType
Public Enumeration OutputType
Public Enumeration OutputType
public enum class OutputType
public enum class OutputType
Members
Member name | Value | Description
All | 0 | Converts the full document.
Range | 1 | Converts the contents of a range using the starting and ending positions.
See Also


PowerPointVersion Enumeration

PowerPointVersion Enumeration Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
PowerPoint version enumeration

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum PowerPointVersion
public enum PowerPointVersion
Public Enumeration PowerPointVersion
Public Enumeration PowerPointVersion
public enum class PowerPointVersion
public enum class PowerPointVersion
Members
Member name | Value | Description
PowerPoint_2003 | 11 | The PowerPoint 2003
PowerPoint_2007 | 12 | The PowerPoint 2007
PowerPoint_2010 | 14 | The PowerPoint 2010
PowerPoint_2013 | 15 | The PowerPoint 2013
See Also


PresentationConverter Class

PresentationConverter Class Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
The PresentationConverter class it a main class of Conaito PowerPoint2Html5 SDK. It provides methods and properties to convert PowerPoint presentations to HTML 5 To start work with SDK creates an instance of the PresentationConverter.
Inheritance Hierarchy
Online System Object
Online System MarshalByRefObject
Conaito.PPT2HTML5 PresentationConverter

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public sealed class PresentationConverter : MarshalByRefObject
public sealed class PresentationConverter : MarshalByRefObject
Public NotInheritable Class PresentationConverter
    Inherits MarshalByRefObject
Public NotInheritable Class PresentationConverter
    Inherits MarshalByRefObject
public ref class PresentationConverter sealed : public MarshalByRefObject
public ref class PresentationConverter sealed : public MarshalByRefObject
See Also
PresentationConverter Members


PresentationConverter Members

PresentationConverter Members Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK

The PresentationConverter type exposes the following members.
Constructors
 | Name | Description
Public method | PresentationConverter | Initializes a new instance of the PresentationConverter class
Back to Top
Methods
 | Name | Description
Public method | ConvertToHTML5 | Converts to HTML5.
Public method | ConvertToHTML5Async | Converts to HTML5 async.
Public method | GenerateThumbnails(String, Single, ImageFormat) | Generates the thumbnails.
Public method | GenerateThumbnails(String, Int32, Int32, ImageFormat) | Generates the thumbnails.
Public method | GenerateThumbnailsAsync | Generates the thumbnails async.
Public method | GetLicenseInfo | Gets the license info.
Public method | GetVersion | Gets the sdk version.
Public method | IsLicenseValid | Determines whether [is license valid]. (Trial or Full)
Public method | OpenPresentation | Opens the presentation.
Public method | OpenPresentationAsync | Opens the presentation async.
Public method | SetLicenseKey | Sets the license key.
 | TestEnvironment | Tests the environment. Detect PowerPoint installing and version.
Back to Top
Properties
 | Name | Description
Public property | IsPresentationOpened | A boolean value which indicates if the presentation has been opened
Public property | Settings | Providing properties the adjustment of the presentation conversion parameters
Public property | Version | A string representation of Conaito PowerPoint2HTML5 SDK version
Back to Top
Events
 | Name | Description
Public event | OnAudioConversionFinish | Occurs when [on audio conversion finish].
Public event | OnAudioConversionStart | Occurs when [on audio conversion start].
Public event | OnConversionEnd | Occurs when [on conversion end].
Public event | OnPresentationOpened | Occurs when [on presentation opened].
Public event | OnShapeProcess | Occurs when [on shape process].
Public event | OnSlideProcess | Occurs when [on slide process].
Public event | OnThumbItemProcess | Occurs when [on thumb item process].
Public event | OnThumbsGenerated | Occurs when [on thumbs generated].
Public event | OnVideoConversionFinish | Occurs when [on video conversion finish].
Public event | OnVideoConversionStart | Occurs when [on video conversion start].
Back to Top
See Also
PresentationConverter Class


PresentationConverter Constructor

PresentationConverter Constructor Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Initializes a new instance of the PresentationConverter class

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PresentationConverter()
public PresentationConverter()
Public Sub New
Public Sub New
public:
PresentationConverter()
public:
PresentationConverter()
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter Methods

PresentationConverter Methods Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDKThe PresentationConverter type exposes the following members.
Methods
 | Name | Description
Public method | ConvertToHTML5 | Converts to HTML5.
Public method | ConvertToHTML5Async | Converts to HTML5 async.
Public method | GenerateThumbnails(String, Single, ImageFormat) | Generates the thumbnails.
Public method | GenerateThumbnails(String, Int32, Int32, ImageFormat) | Generates the thumbnails.
Public method | GenerateThumbnailsAsync | Generates the thumbnails async.
Public method | GetLicenseInfo | Gets the license info.
Public method | GetVersion | Gets the sdk version.
Public method | IsLicenseValid | Determines whether [is license valid]. (Trial or Full)
Public method | OpenPresentation | Opens the presentation.
Public method | OpenPresentationAsync | Opens the presentation async.
Public method | SetLicenseKey | Sets the license key.
 | TestEnvironment | Tests the environment. Detect PowerPoint installing and version.
Back to Top
See Also
PresentationConverter Class


PresentationConverter.ConvertToHTML5 Method

PresentationConverter ConvertToHTML5 Method Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Converts to HTML5.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ConversionFinishResult ConvertToHTML5(
    string htmlPath
)
public ConversionFinishResult ConvertToHTML5(
    string htmlPath
)
Public Function ConvertToHTML5 (
    htmlPath As String
) As ConversionFinishResult
Public Function ConvertToHTML5 (
    htmlPath As String
) As ConversionFinishResult
public:
ConversionFinishResult^ ConvertToHTML5(
    String^ htmlPath
)
public:
ConversionFinishResult^ ConvertToHTML5(
    String^ htmlPath
)
Parameters
htmlPath
Type:   Online System String
The HTML path.
Return Value
Type: ConversionFinishResult
Exceptions
Exception | Condition
Online System Exception | License is not valid
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.ConvertToHTML5Async Method

PresentationConverter ConvertToHTML5Async Method Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Converts to HTML5 async.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ConvertToHTML5Async(
    string htmlPath
)
public void ConvertToHTML5Async(
    string htmlPath
)
Public Sub ConvertToHTML5Async (
    htmlPath As String
)
Public Sub ConvertToHTML5Async (
    htmlPath As String
)
public:
void ConvertToHTML5Async(
    String^ htmlPath
)
public:
void ConvertToHTML5Async(
    String^ htmlPath
)
Parameters
htmlPath
Type:   Online System String
The HTML path.
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.GenerateThumbnails Method

PresentationConverter GenerateThumbnails Method Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Overload List
 | Name | Description
Public method | GenerateThumbnails(String, Single, ImageFormat) | Generates the thumbnails.
Public method | GenerateThumbnails(String, Int32, Int32, ImageFormat) | Generates the thumbnails.
Back to Top
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.GenerateThumbnails Method (String, Single, ImageFormat)

PresentationConverter GenerateThumbnails Method (String, Single, ImageFormat) Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Generates the thumbnails.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ThumbsGeneratedResult GenerateThumbnails(
    string thumbsFolder,
    float scale = 1f,
    ImageFormat imageFormat = ImageFormat.Png
)
public ThumbsGeneratedResult GenerateThumbnails(
    string thumbsFolder,
    float scale = 1f,
    ImageFormat imageFormat = ImageFormat.Png
)
Public Function GenerateThumbnails (
    thumbsFolder As String,
    Optional scale As Single = 1F,
    Optional imageFormat As ImageFormat = ImageFormat.Png
) As ThumbsGeneratedResult
Public Function GenerateThumbnails (
    thumbsFolder As String,
    Optional scale As Single = 1F,
    Optional imageFormat As ImageFormat = ImageFormat.Png
) As ThumbsGeneratedResult
public:
ThumbsGeneratedResult^ GenerateThumbnails(
    String^ thumbsFolder,
    float scale = 1f,
    ImageFormat imageFormat = ImageFormat::Png
)
public:
ThumbsGeneratedResult^ GenerateThumbnails(
    String^ thumbsFolder,
    float scale = 1f,
    ImageFormat imageFormat = ImageFormat::Png
)
Parameters
thumbsFolder
Type:   Online System String
The thumbs folder.
scale (Optional)
Type:   Online System Single
The scale.
imageFormat (Optional)
Type: Conaito.PPT2HTML5 ImageFormat
Return Value
Type: ThumbsGeneratedResult
Exceptions
Exception | Condition
Online System Exception | License is not valid
See Also
PresentationConverter Class
PresentationConverter Members
GenerateThumbnails Overload


PresentationConverter.GenerateThumbnails Method (String, Int32, Int32, ImageFormat)

PresentationConverter GenerateThumbnails Method (String, Int32, Int32, ImageFormat) Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Generates the thumbnails.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ThumbsGeneratedResult GenerateThumbnails(
    string thumbsFolder,
    int mxaWidth = 800,
    int maxHeight = 600,
    ImageFormat imageFormat = ImageFormat.Png
)
public ThumbsGeneratedResult GenerateThumbnails(
    string thumbsFolder,
    int mxaWidth = 800,
    int maxHeight = 600,
    ImageFormat imageFormat = ImageFormat.Png
)
Public Function GenerateThumbnails (
    thumbsFolder As String,
    Optional mxaWidth As Integer = 800,
    Optional maxHeight As Integer = 600,
    Optional imageFormat As ImageFormat = ImageFormat.Png
) As ThumbsGeneratedResult
Public Function GenerateThumbnails (
    thumbsFolder As String,
    Optional mxaWidth As Integer = 800,
    Optional maxHeight As Integer = 600,
    Optional imageFormat As ImageFormat = ImageFormat.Png
) As ThumbsGeneratedResult
public:
ThumbsGeneratedResult^ GenerateThumbnails(
    String^ thumbsFolder,
    int mxaWidth = 800,
    int maxHeight = 600,
    ImageFormat imageFormat = ImageFormat::Png
)
public:
ThumbsGeneratedResult^ GenerateThumbnails(
    String^ thumbsFolder,
    int mxaWidth = 800,
    int maxHeight = 600,
    ImageFormat imageFormat = ImageFormat::Png
)
Parameters
thumbsFolder
Type:   Online System String
The thumbs folder.
mxaWidth (Optional)
Type:   Online System Int32
maxHeight (Optional)
Type:   Online System Int32
imageFormat (Optional)
Type: Conaito.PPT2HTML5 ImageFormat
Return Value
Type: ThumbsGeneratedResult
Exceptions
Exception | Condition
Online System Exception | License is not valid
See Also
PresentationConverter Class
PresentationConverter Members
GenerateThumbnails Overload


PresentationConverter.GenerateThumbnailsAsync Method

PresentationConverter GenerateThumbnailsAsync Method Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Generates the thumbnails async.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void GenerateThumbnailsAsync(
    string thumbsFolder,
    int scale = 1,
    ImageFormat imageFormat = ImageFormat.Png
)
public void GenerateThumbnailsAsync(
    string thumbsFolder,
    int scale = 1,
    ImageFormat imageFormat = ImageFormat.Png
)
Public Sub GenerateThumbnailsAsync (
    thumbsFolder As String,
    Optional scale As Integer = 1,
    Optional imageFormat As ImageFormat = ImageFormat.Png
)
Public Sub GenerateThumbnailsAsync (
    thumbsFolder As String,
    Optional scale As Integer = 1,
    Optional imageFormat As ImageFormat = ImageFormat.Png
)
public:
void GenerateThumbnailsAsync(
    String^ thumbsFolder,
    int scale = 1,
    ImageFormat imageFormat = ImageFormat::Png
)
public:
void GenerateThumbnailsAsync(
    String^ thumbsFolder,
    int scale = 1,
    ImageFormat imageFormat = ImageFormat::Png
)
Parameters
thumbsFolder
Type:   Online System String
The thumbs folder.
scale (Optional)
Type:   Online System Int32
The scale.
imageFormat (Optional)
Type: Conaito.PPT2HTML5 ImageFormat
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.GetLicenseInfo Method

PresentationConverter GetLicenseInfo Method Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets the license info.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetLicenseInfo()
public string GetLicenseInfo()
Public Function GetLicenseInfo As String
Public Function GetLicenseInfo As String
public:
String^ GetLicenseInfo()
public:
String^ GetLicenseInfo()
Return Value
Type:   Online String
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.GetVersion Method

PresentationConverter GetVersion Method Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets the sdk version.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string GetVersion()
public string GetVersion()
Public Function GetVersion As String
Public Function GetVersion As String
public:
String^ GetVersion()
public:
String^ GetVersion()
Return Value
Type:   Online String
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.IsLicenseValid Method

PresentationConverter IsLicenseValid Method Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Determines whether [is license valid]. (Trial or Full)

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsLicenseValid()
public bool IsLicenseValid()
Public Function IsLicenseValid As Boolean
Public Function IsLicenseValid As Boolean
public:
bool IsLicenseValid()
public:
bool IsLicenseValid()
Return Value
Type:   Online Boolean
true if [is license valid]; otherwise, false.

See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.OpenPresentation Method

PresentationConverter OpenPresentation Method Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Opens the presentation.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PresentationOpenedResult OpenPresentation(
    string sourcePresentationPath
)
public PresentationOpenedResult OpenPresentation(
    string sourcePresentationPath
)
Public Function OpenPresentation (
    sourcePresentationPath As String
) As PresentationOpenedResult
Public Function OpenPresentation (
    sourcePresentationPath As String
) As PresentationOpenedResult
public:
PresentationOpenedResult^ OpenPresentation(
    String^ sourcePresentationPath
)
public:
PresentationOpenedResult^ OpenPresentation(
    String^ sourcePresentationPath
)
Parameters
sourcePresentationPath
Type:   Online System String
The source presentation path.
Return Value
Type: PresentationOpenedResult
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.OpenPresentationAsync Method

PresentationConverter OpenPresentationAsync Method Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Opens the presentation async.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void OpenPresentationAsync(
    string sourcePresentationPath
)
public void OpenPresentationAsync(
    string sourcePresentationPath
)
Public Sub OpenPresentationAsync (
    sourcePresentationPath As String
)
Public Sub OpenPresentationAsync (
    sourcePresentationPath As String
)
public:
void OpenPresentationAsync(
    String^ sourcePresentationPath
)
public:
void OpenPresentationAsync(
    String^ sourcePresentationPath
)
Parameters
sourcePresentationPath
Type:   Online System String
The source presentation path. (*.ppt, *.pptx, *.odp)
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.SetLicenseKey Method

PresentationConverter SetLicenseKey Method Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Sets the license key.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SetLicenseKey(
    string licenseKey
)
public void SetLicenseKey(
    string licenseKey
)
Public Sub SetLicenseKey (
    licenseKey As String
)
Public Sub SetLicenseKey (
    licenseKey As String
)
public:
void SetLicenseKey(
    String^ licenseKey
)
public:
void SetLicenseKey(
    String^ licenseKey
)
Parameters
licenseKey
Type:   Online System String
The license key.
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.TestEnvironment Method

PresentationConverter TestEnvironment Method Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Tests the environment. Detect PowerPoint installing and version.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static EnvironmentInfo TestEnvironment()
public static EnvironmentInfo TestEnvironment()
Public Shared Function TestEnvironment As EnvironmentInfo
Public Shared Function TestEnvironment As EnvironmentInfo
public:
static EnvironmentInfo^ TestEnvironment()
public:
static EnvironmentInfo^ TestEnvironment()
Return Value
Type: EnvironmentInfo
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter Properties

PresentationConverter Properties Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDKThe PresentationConverter type exposes the following members.
Properties
 | Name | Description
Public property | IsPresentationOpened | A boolean value which indicates if the presentation has been opened
Public property | Settings | Providing properties the adjustment of the presentation conversion parameters
Public property | Version | A string representation of Conaito PowerPoint2HTML5 SDK version
Back to Top
See Also
PresentationConverter Class


PresentationConverter.IsPresentationOpened Property

PresentationConverter IsPresentationOpened Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
A boolean value which indicates if the presentation has been opened

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsPresentationOpened { get; }
public bool IsPresentationOpened { get; }
Public ReadOnly Property IsPresentationOpened As Boolean
    Get
Public ReadOnly Property IsPresentationOpened As Boolean
    Get
public:
property bool IsPresentationOpened {
    bool get ();
}
public:
property bool IsPresentationOpened {
    bool get ();
}
Property Value
Type:   Online Boolean
true if opened; otherwise, false.

See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.Settings Property

PresentationConverter Settings Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Providing properties the adjustment of the presentation conversion parameters

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Settings Settings { get; private set; }
public Settings Settings { get; private set; }
Public Property Settings As Settings
    Get
    Private Set
Public Property Settings As Settings
    Get
    Private Set
public:
property Settings^ Settings {
    Settings^ get ();
    private: void set (Settings^ value);
}
public:
property Settings^ Settings {
    Settings^ get ();
    private: void set (Settings^ value);
}
Property Value
Type: Settings

            The settings.

See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.Version Property

PresentationConverter Version Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
A string representation of Conaito PowerPoint2HTML5 SDK version

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Version { get; }
public string Version { get; }
Public ReadOnly Property Version As String
    Get
Public ReadOnly Property Version As String
    Get
public:
property String^ Version {
    String^ get ();
}
public:
property String^ Version {
    String^ get ();
}
Property Value
Type:   Online String

            The version.

See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter Events

PresentationConverter Events Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDKThe PresentationConverter type exposes the following members.
Events
 | Name | Description
Public event | OnAudioConversionFinish | Occurs when [on audio conversion finish].
Public event | OnAudioConversionStart | Occurs when [on audio conversion start].
Public event | OnConversionEnd | Occurs when [on conversion end].
Public event | OnPresentationOpened | Occurs when [on presentation opened].
Public event | OnShapeProcess | Occurs when [on shape process].
Public event | OnSlideProcess | Occurs when [on slide process].
Public event | OnThumbItemProcess | Occurs when [on thumb item process].
Public event | OnThumbsGenerated | Occurs when [on thumbs generated].
Public event | OnVideoConversionFinish | Occurs when [on video conversion finish].
Public event | OnVideoConversionStart | Occurs when [on video conversion start].
Back to Top
See Also
PresentationConverter Class


PresentationConverter.OnAudioConversionFinish Event

PresentationConverter OnAudioConversionFinish Event Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Occurs when [on audio conversion finish].

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event OnAudioConversionFinish OnAudioConversionFinish
public event OnAudioConversionFinish OnAudioConversionFinish
Public Event OnAudioConversionFinish As OnAudioConversionFinish
Public Event OnAudioConversionFinish As OnAudioConversionFinish
public:
 event OnAudioConversionFinish^ OnAudioConversionFinish {
    void add (OnAudioConversionFinish^ value);
    void remove (OnAudioConversionFinish^ value);
}
public:
 event OnAudioConversionFinish^ OnAudioConversionFinish {
    void add (OnAudioConversionFinish^ value);
    void remove (OnAudioConversionFinish^ value);
}
Value
Type: Conaito.PPT2HTML5 OnAudioConversionFinish
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.OnAudioConversionStart Event

PresentationConverter OnAudioConversionStart Event Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Occurs when [on audio conversion start].

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event OnAudioConversionStart OnAudioConversionStart
public event OnAudioConversionStart OnAudioConversionStart
Public Event OnAudioConversionStart As OnAudioConversionStart
Public Event OnAudioConversionStart As OnAudioConversionStart
public:
 event OnAudioConversionStart^ OnAudioConversionStart {
    void add (OnAudioConversionStart^ value);
    void remove (OnAudioConversionStart^ value);
}
public:
 event OnAudioConversionStart^ OnAudioConversionStart {
    void add (OnAudioConversionStart^ value);
    void remove (OnAudioConversionStart^ value);
}
Value
Type: Conaito.PPT2HTML5 OnAudioConversionStart
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.OnConversionEnd Event

PresentationConverter OnConversionEnd Event Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Occurs when [on conversion end].

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event OnConversionFinishDelegate OnConversionEnd
public event OnConversionFinishDelegate OnConversionEnd
Public Event OnConversionEnd As OnConversionFinishDelegate
Public Event OnConversionEnd As OnConversionFinishDelegate
public:
 event OnConversionFinishDelegate^ OnConversionEnd {
    void add (OnConversionFinishDelegate^ value);
    void remove (OnConversionFinishDelegate^ value);
}
public:
 event OnConversionFinishDelegate^ OnConversionEnd {
    void add (OnConversionFinishDelegate^ value);
    void remove (OnConversionFinishDelegate^ value);
}
Value
Type: Conaito.PPT2HTML5 OnConversionFinishDelegate
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.OnPresentationOpened Event

PresentationConverter OnPresentationOpened Event Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Occurs when [on presentation opened].

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event OnPresentationOpenedDelegate OnPresentationOpened
public event OnPresentationOpenedDelegate OnPresentationOpened
Public Event OnPresentationOpened As OnPresentationOpenedDelegate
Public Event OnPresentationOpened As OnPresentationOpenedDelegate
public:
 event OnPresentationOpenedDelegate^ OnPresentationOpened {
    void add (OnPresentationOpenedDelegate^ value);
    void remove (OnPresentationOpenedDelegate^ value);
}
public:
 event OnPresentationOpenedDelegate^ OnPresentationOpened {
    void add (OnPresentationOpenedDelegate^ value);
    void remove (OnPresentationOpenedDelegate^ value);
}
Value
Type: Conaito.PPT2HTML5 OnPresentationOpenedDelegate
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.OnShapeProcess Event

PresentationConverter OnShapeProcess Event Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Occurs when [on shape process].

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event OnShapeProcessDelegate OnShapeProcess
public event OnShapeProcessDelegate OnShapeProcess
Public Event OnShapeProcess As OnShapeProcessDelegate
Public Event OnShapeProcess As OnShapeProcessDelegate
public:
 event OnShapeProcessDelegate^ OnShapeProcess {
    void add (OnShapeProcessDelegate^ value);
    void remove (OnShapeProcessDelegate^ value);
}
public:
 event OnShapeProcessDelegate^ OnShapeProcess {
    void add (OnShapeProcessDelegate^ value);
    void remove (OnShapeProcessDelegate^ value);
}
Value
Type: Conaito.PPT2HTML5 OnShapeProcessDelegate
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.OnSlideProcess Event

PresentationConverter OnSlideProcess Event Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Occurs when [on slide process].

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event OnSlideProcessDelegate OnSlideProcess
public event OnSlideProcessDelegate OnSlideProcess
Public Event OnSlideProcess As OnSlideProcessDelegate
Public Event OnSlideProcess As OnSlideProcessDelegate
public:
 event OnSlideProcessDelegate^ OnSlideProcess {
    void add (OnSlideProcessDelegate^ value);
    void remove (OnSlideProcessDelegate^ value);
}
public:
 event OnSlideProcessDelegate^ OnSlideProcess {
    void add (OnSlideProcessDelegate^ value);
    void remove (OnSlideProcessDelegate^ value);
}
Value
Type: Conaito.PPT2HTML5 OnSlideProcessDelegate
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.OnThumbItemProcess Event

PresentationConverter OnThumbItemProcess Event Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Occurs when [on thumb item process].

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event OnThumbItemProcessDelegate OnThumbItemProcess
public event OnThumbItemProcessDelegate OnThumbItemProcess
Public Event OnThumbItemProcess As OnThumbItemProcessDelegate
Public Event OnThumbItemProcess As OnThumbItemProcessDelegate
public:
 event OnThumbItemProcessDelegate^ OnThumbItemProcess {
    void add (OnThumbItemProcessDelegate^ value);
    void remove (OnThumbItemProcessDelegate^ value);
}
public:
 event OnThumbItemProcessDelegate^ OnThumbItemProcess {
    void add (OnThumbItemProcessDelegate^ value);
    void remove (OnThumbItemProcessDelegate^ value);
}
Value
Type: Conaito.PPT2HTML5 OnThumbItemProcessDelegate
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.OnThumbsGenerated Event

PresentationConverter OnThumbsGenerated Event Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Occurs when [on thumbs generated].

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event OnThumbsGeneratedDelegate OnThumbsGenerated
public event OnThumbsGeneratedDelegate OnThumbsGenerated
Public Event OnThumbsGenerated As OnThumbsGeneratedDelegate
Public Event OnThumbsGenerated As OnThumbsGeneratedDelegate
public:
 event OnThumbsGeneratedDelegate^ OnThumbsGenerated {
    void add (OnThumbsGeneratedDelegate^ value);
    void remove (OnThumbsGeneratedDelegate^ value);
}
public:
 event OnThumbsGeneratedDelegate^ OnThumbsGenerated {
    void add (OnThumbsGeneratedDelegate^ value);
    void remove (OnThumbsGeneratedDelegate^ value);
}
Value
Type: Conaito.PPT2HTML5 OnThumbsGeneratedDelegate
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.OnVideoConversionFinish Event

PresentationConverter OnVideoConversionFinish Event Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Occurs when [on video conversion finish].

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event OnVideoConversionFinish OnVideoConversionFinish
public event OnVideoConversionFinish OnVideoConversionFinish
Public Event OnVideoConversionFinish As OnVideoConversionFinish
Public Event OnVideoConversionFinish As OnVideoConversionFinish
public:
 event OnVideoConversionFinish^ OnVideoConversionFinish {
    void add (OnVideoConversionFinish^ value);
    void remove (OnVideoConversionFinish^ value);
}
public:
 event OnVideoConversionFinish^ OnVideoConversionFinish {
    void add (OnVideoConversionFinish^ value);
    void remove (OnVideoConversionFinish^ value);
}
Value
Type: Conaito.PPT2HTML5 OnVideoConversionFinish
See Also
PresentationConverter Class
PresentationConverter Members


PresentationConverter.OnVideoConversionStart Event

PresentationConverter OnVideoConversionStart Event Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Occurs when [on video conversion start].

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public event OnVideoConversionStart OnVideoConversionStart
public event OnVideoConversionStart OnVideoConversionStart
Public Event OnVideoConversionStart As OnVideoConversionStart
Public Event OnVideoConversionStart As OnVideoConversionStart
public:
 event OnVideoConversionStart^ OnVideoConversionStart {
    void add (OnVideoConversionStart^ value);
    void remove (OnVideoConversionStart^ value);
}
public:
 event OnVideoConversionStart^ OnVideoConversionStart {
    void add (OnVideoConversionStart^ value);
    void remove (OnVideoConversionStart^ value);
}
Value
Type: Conaito.PPT2HTML5 OnVideoConversionStart
See Also
PresentationConverter Class
PresentationConverter Members


PresentationInfo Class

PresentationInfo Class Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
PresentationInfo class
Inheritance Hierarchy
Online System Object
Conaito.PPT2HTML5 PresentationInfo

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class PresentationInfo
[SerializableAttribute]
public sealed class PresentationInfo
<SerializableAttribute>
Public NotInheritable Class PresentationInfo
<SerializableAttribute>
Public NotInheritable Class PresentationInfo
[SerializableAttribute]
public ref class PresentationInfo sealed
[SerializableAttribute]
public ref class PresentationInfo sealed
See Also
PresentationInfo Members


PresentationInfo Members

PresentationInfo Members Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK

The PresentationInfo type exposes the following members.
Properties
 | Name | Description
Public property | Author | Gets the author.
Public property | Height | Gets the height.
Public property | Path | Gets the PowerPoint document path.
Public property | SlidesCount | Gets the slides count.
Public property | Title | Gets the title.
Public property | Width | Gets the width.
Back to Top
See Also
PresentationInfo Class


PresentationInfo Properties

PresentationInfo Properties Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDKThe PresentationInfo type exposes the following members.
Properties
 | Name | Description
Public property | Author | Gets the author.
Public property | Height | Gets the height.
Public property | Path | Gets the PowerPoint document path.
Public property | SlidesCount | Gets the slides count.
Public property | Title | Gets the title.
Public property | Width | Gets the width.
Back to Top
See Also
PresentationInfo Class


PresentationInfo.Author Property

PresentationInfo Author Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets the author.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Author { get; internal set; }
public string Author { get; internal set; }
Public Property Author As String
    Get
    Friend Set
Public Property Author As String
    Get
    Friend Set
public:
property String^ Author {
    String^ get ();
    internal: void set (String^ value);
}
public:
property String^ Author {
    String^ get ();
    internal: void set (String^ value);
}
Property Value
Type:   Online String

            The author.

See Also
PresentationInfo Class
PresentationInfo Members


PresentationInfo.Height Property

PresentationInfo Height Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets the height.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Height { get; internal set; }
public int Height { get; internal set; }
Public Property Height As Integer
    Get
    Friend Set
Public Property Height As Integer
    Get
    Friend Set
public:
property int Height {
    int get ();
    internal: void set (int value);
}
public:
property int Height {
    int get ();
    internal: void set (int value);
}
Property Value
Type:   Online Int32

            The height.

See Also
PresentationInfo Class
PresentationInfo Members


PresentationInfo.Path Property

PresentationInfo Path Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets the PowerPoint document path.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Path { get; internal set; }
public string Path { get; internal set; }
Public Property Path As String
    Get
    Friend Set
Public Property Path As String
    Get
    Friend Set
public:
property String^ Path {
    String^ get ();
    internal: void set (String^ value);
}
public:
property String^ Path {
    String^ get ();
    internal: void set (String^ value);
}
Property Value
Type:   Online String

            The path.

See Also
PresentationInfo Class
PresentationInfo Members


PresentationInfo.SlidesCount Property

PresentationInfo SlidesCount Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets the slides count.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int SlidesCount { get; internal set; }
public int SlidesCount { get; internal set; }
Public Property SlidesCount As Integer
    Get
    Friend Set
Public Property SlidesCount As Integer
    Get
    Friend Set
public:
property int SlidesCount {
    int get ();
    internal: void set (int value);
}
public:
property int SlidesCount {
    int get ();
    internal: void set (int value);
}
Property Value
Type:   Online Int32

            The slides count.

See Also
PresentationInfo Class
PresentationInfo Members


PresentationInfo.Title Property

PresentationInfo Title Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets the title.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Title { get; internal set; }
public string Title { get; internal set; }
Public Property Title As String
    Get
    Friend Set
Public Property Title As String
    Get
    Friend Set
public:
property String^ Title {
    String^ get ();
    internal: void set (String^ value);
}
public:
property String^ Title {
    String^ get ();
    internal: void set (String^ value);
}
Property Value
Type:   Online String

            The title.

See Also
PresentationInfo Class
PresentationInfo Members


PresentationInfo.Width Property

PresentationInfo Width Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets the width.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Width { get; internal set; }
public int Width { get; internal set; }
Public Property Width As Integer
    Get
    Friend Set
Public Property Width As Integer
    Get
    Friend Set
public:
property int Width {
    int get ();
    internal: void set (int value);
}
public:
property int Width {
    int get ();
    internal: void set (int value);
}
Property Value
Type:   Online Int32

            The width.

See Also
PresentationInfo Class
PresentationInfo Members


PresentationOpenedResult Class

PresentationOpenedResult Class Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
PresentationOpenedResult class
Inheritance Hierarchy
Online System Object
Conaito.PPT2HTML5 OperationResult
Conaito.PPT2HTML5 PresentationOpenedResult

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class PresentationOpenedResult : OperationResult
[SerializableAttribute]
public class PresentationOpenedResult : OperationResult
<SerializableAttribute>
Public Class PresentationOpenedResult
    Inherits OperationResult
<SerializableAttribute>
Public Class PresentationOpenedResult
    Inherits OperationResult
[SerializableAttribute]
public ref class PresentationOpenedResult : public OperationResult
[SerializableAttribute]
public ref class PresentationOpenedResult : public OperationResult
See Also
PresentationOpenedResult Members


PresentationOpenedResult Members

PresentationOpenedResult Members Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK

The PresentationOpenedResult type exposes the following members.
Properties
 | Name | Description
Public property | Presentation | Gets the PowerPoint presentation.
Back to Top
See Also
PresentationOpenedResult Class


PresentationOpenedResult Properties

PresentationOpenedResult Properties Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDKThe PresentationOpenedResult type exposes the following members.
Properties
 | Name | Description
Public property | Presentation | Gets the PowerPoint presentation.
Back to Top
See Also
PresentationOpenedResult Class


PresentationOpenedResult.Presentation Property

PresentationOpenedResult Presentation Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets the PowerPoint presentation.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public PresentationInfo Presentation { get; internal set; }
public PresentationInfo Presentation { get; internal set; }
Public Property Presentation As PresentationInfo
    Get
    Friend Set
Public Property Presentation As PresentationInfo
    Get
    Friend Set
public:
property PresentationInfo^ Presentation {
    PresentationInfo^ get ();
    internal: void set (PresentationInfo^ value);
}
public:
property PresentationInfo^ Presentation {
    PresentationInfo^ get ();
    internal: void set (PresentationInfo^ value);
}
Property Value
Type: PresentationInfo

            The presentation.

See Also
PresentationOpenedResult Class
PresentationOpenedResult Members


Settings Class

Settings Class Conaito PowerPoint-to-HTML5 SDK Documentation
ConverterSettings class
Inheritance Hierarchy
Online System Object
Conaito.PPT2HTML5 Settings

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public sealed class Settings
[SerializableAttribute]
public sealed class Settings
<SerializableAttribute>
Public NotInheritable Class Settings
<SerializableAttribute>
Public NotInheritable Class Settings
[SerializableAttribute]
public ref class Settings sealed
[SerializableAttribute]
public ref class Settings sealed
See Also
Settings Members


Settings Members

Settings Members Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK

The Settings type exposes the following members.
Properties
 | Name | Description
Public property | CustomLogo | Gets or sets the custom banner. Works only on FULL license mode.
Public property | CustomLogoURL | Gets or sets the custom logo URL.
Public property | ExportThumbnails | Gets or sets a value indicating whether [export thumbnails].
Public property | GenerateXml | Gets or sets a value indicating whether [generate XML].
Public property | HtmlAuthor | Title that will be put on html meta tag, example If value is null or empty title will automatically get from original PowerPoint presentation author.
Public property | HtmlDescription | Description that will be put on html meta tag, example
Public property | HtmlKeywords | Keywords that will be put on html meta tag, example
Public property | HtmlTemplateFilePath | Gets or sets the output HTML Player template file path. If null - use default(embedded) template
Public property | HtmlTitle | Title that will be put on html title tag, example Presentation titletitle>. If value is null or empty title will automatically get from original PowerPoint presentation title.
Public property | Media | Provide multimedia conversion options
Public property | OutputRange | Output Range, for example: 1-30,31,25
Public property | OutputType | Gets or sets output range of the document.
Public property | ThumbnailsFormat | Gets or sets the thumbnails format. (png, jpeg or bmp)
Public property | ThumbnailsScale | Gets or sets the thumbnails scale.
Back to Top
See Also
Settings Class


Settings Properties

Settings Properties Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDKThe Settings type exposes the following members.
Properties
 | Name | Description
Public property | CustomLogo | Gets or sets the custom banner. Works only on FULL license mode.
Public property | CustomLogoURL | Gets or sets the custom logo URL.
Public property | ExportThumbnails | Gets or sets a value indicating whether [export thumbnails].
Public property | GenerateXml | Gets or sets a value indicating whether [generate XML].
Public property | HtmlAuthor | Title that will be put on html meta tag, example If value is null or empty title will automatically get from original PowerPoint presentation author.
Public property | HtmlDescription | Description that will be put on html meta tag, example
Public property | HtmlKeywords | Keywords that will be put on html meta tag, example
Public property | HtmlTemplateFilePath | Gets or sets the output HTML Player template file path. If null - use default(embedded) template
Public property | HtmlTitle | Title that will be put on html title tag, example Presentation titletitle>. If value is null or empty title will automatically get from original PowerPoint presentation title.
Public property | Media | Provide multimedia conversion options
Public property | OutputRange | Output Range, for example: 1-30,31,25
Public property | OutputType | Gets or sets output range of the document.
Public property | ThumbnailsFormat | Gets or sets the thumbnails format. (png, jpeg or bmp)
Public property | ThumbnailsScale | Gets or sets the thumbnails scale.
Back to Top
See Also
Settings Class


Settings.CustomLogo Property

Settings CustomLogo Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets or sets the custom banner. Works only on FULL license mode.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Bitmap CustomLogo { get; set; }
public Bitmap CustomLogo { get; set; }
Public Property CustomLogo As Bitmap
    Get
    Set
Public Property CustomLogo As Bitmap
    Get
    Set
public:
property Bitmap^ CustomLogo {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
public:
property Bitmap^ CustomLogo {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
Property Value
Type:   Online Bitmap
The custom banner.
See Also
Settings Class
Settings Members


Settings.CustomLogoURL Property

Settings CustomLogoURL Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets or sets the custom logo URL.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CustomLogoURL { get; set; }
public string CustomLogoURL { get; set; }
Public Property CustomLogoURL As String
    Get
    Set
Public Property CustomLogoURL As String
    Get
    Set
public:
property String^ CustomLogoURL {
    String^ get ();
    void set (String^ value);
}
public:
property String^ CustomLogoURL {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
The custom logo URL.
See Also
Settings Class
Settings Members


Settings.ExportThumbnails Property

Settings ExportThumbnails Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets or sets a value indicating whether [export thumbnails].

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool ExportThumbnails { get; set; }
public bool ExportThumbnails { get; set; }
Public Property ExportThumbnails As Boolean
    Get
    Set
Public Property ExportThumbnails As Boolean
    Get
    Set
public:
property bool ExportThumbnails {
    bool get ();
    void set (bool value);
}
public:
property bool ExportThumbnails {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
true if [export thumbnails]; otherwise, false.

See Also
Settings Class
Settings Members


Settings.GenerateXml Property

Settings GenerateXml Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets or sets a value indicating whether [generate XML].

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool GenerateXml { get; set; }
public bool GenerateXml { get; set; }
Public Property GenerateXml As Boolean
    Get
    Set
Public Property GenerateXml As Boolean
    Get
    Set
public:
property bool GenerateXml {
    bool get ();
    void set (bool value);
}
public:
property bool GenerateXml {
    bool get ();
    void set (bool value);
}
Property Value
Type:   Online Boolean
true if [generate XML]; otherwise, false.

See Also
Settings Class
Settings Members


Settings.HtmlAuthor Property

Settings HtmlAuthor Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Title that will be put on html meta tag, example If value is null or empty title will automatically get from original PowerPoint presentation author.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string HtmlAuthor { get; set; }
public string HtmlAuthor { get; set; }
Public Property HtmlAuthor As String
    Get
    Set
Public Property HtmlAuthor As String
    Get
    Set
public:
property String^ HtmlAuthor {
    String^ get ();
    void set (String^ value);
}
public:
property String^ HtmlAuthor {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
See Also
Settings Class
Settings Members


Settings.HtmlDescription Property

Settings HtmlDescription Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Description that will be put on html meta tag, example

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string HtmlDescription { get; set; }
public string HtmlDescription { get; set; }
Public Property HtmlDescription As String
    Get
    Set
Public Property HtmlDescription As String
    Get
    Set
public:
property String^ HtmlDescription {
    String^ get ();
    void set (String^ value);
}
public:
property String^ HtmlDescription {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
See Also
Settings Class
Settings Members


Settings.HtmlKeywords Property

Settings HtmlKeywords Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Keywords that will be put on html meta tag, example

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string HtmlKeywords { get; set; }
public string HtmlKeywords { get; set; }
Public Property HtmlKeywords As String
    Get
    Set
Public Property HtmlKeywords As String
    Get
    Set
public:
property String^ HtmlKeywords {
    String^ get ();
    void set (String^ value);
}
public:
property String^ HtmlKeywords {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
See Also
Settings Class
Settings Members


Settings.HtmlTemplateFilePath Property

Settings HtmlTemplateFilePath Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets or sets the output HTML Player template file path. If null - use default(embedded) template

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string HtmlTemplateFilePath { get; set; }
public string HtmlTemplateFilePath { get; set; }
Public Property HtmlTemplateFilePath As String
    Get
    Set
Public Property HtmlTemplateFilePath As String
    Get
    Set
public:
property String^ HtmlTemplateFilePath {
    String^ get ();
    void set (String^ value);
}
public:
property String^ HtmlTemplateFilePath {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String

            The HTML template file path.

See Also
Settings Class
Settings Members


Settings.HtmlTitle Property

Settings HtmlTitle Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Title that will be put on html title tag, example Presentation titletitle>. If value is null or empty title will automatically get from original PowerPoint presentation title.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string HtmlTitle { get; set; }
public string HtmlTitle { get; set; }
Public Property HtmlTitle As String
    Get
    Set
Public Property HtmlTitle As String
    Get
    Set
public:
property String^ HtmlTitle {
    String^ get ();
    void set (String^ value);
}
public:
property String^ HtmlTitle {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
See Also
Settings Class
Settings Members


Settings.Media Property

Settings Media Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Provide multimedia conversion options

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MediaSettings Media { get; private set; }
public MediaSettings Media { get; private set; }
Public Property Media As MediaSettings
    Get
    Private Set
Public Property Media As MediaSettings
    Get
    Private Set
public:
property MediaSettings^ Media {
    MediaSettings^ get ();
    private: void set (MediaSettings^ value);
}
public:
property MediaSettings^ Media {
    MediaSettings^ get ();
    private: void set (MediaSettings^ value);
}
Property Value
Type: MediaSettings
See Also
Settings Class
Settings Members


Settings.OutputRange Property

Settings OutputRange Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Output Range, for example: 1-30,31,25

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string OutputRange { get; set; }
public string OutputRange { get; set; }
Public Property OutputRange As String
    Get
    Set
Public Property OutputRange As String
    Get
    Set
public:
property String^ OutputRange {
    String^ get ();
    void set (String^ value);
}
public:
property String^ OutputRange {
    String^ get ();
    void set (String^ value);
}
Property Value
Type:   Online String
See Also
Settings Class
Settings Members


Settings.OutputType Property

Settings OutputType Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets or sets output range of the document.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public OutputType OutputType { get; set; }
public OutputType OutputType { get; set; }
Public Property OutputType As OutputType
    Get
    Set
Public Property OutputType As OutputType
    Get
    Set
public:
property OutputType OutputType {
    OutputType get ();
    void set (OutputType value);
}
public:
property OutputType OutputType {
    OutputType get ();
    void set (OutputType value);
}
Property Value
Type: OutputType
The output type.
See Also
Settings Class
Settings Members


Settings.ThumbnailsFormat Property

Settings ThumbnailsFormat Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets or sets the thumbnails format. (png, jpeg or bmp)

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ImageFormat ThumbnailsFormat { get; set; }
public ImageFormat ThumbnailsFormat { get; set; }
Public Property ThumbnailsFormat As ImageFormat
    Get
    Set
Public Property ThumbnailsFormat As ImageFormat
    Get
    Set
public:
property ImageFormat ThumbnailsFormat {
    ImageFormat get ();
    void set (ImageFormat value);
}
public:
property ImageFormat ThumbnailsFormat {
    ImageFormat get ();
    void set (ImageFormat value);
}
Property Value
Type: ImageFormat

            The thumbnails format.

See Also
Settings Class
Settings Members


Settings.ThumbnailsScale Property

Settings ThumbnailsScale Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets or sets the thumbnails scale.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float ThumbnailsScale { get; set; }
public float ThumbnailsScale { get; set; }
Public Property ThumbnailsScale As Single
    Get
    Set
Public Property ThumbnailsScale As Single
    Get
    Set
public:
property float ThumbnailsScale {
    float get ();
    void set (float value);
}
public:
property float ThumbnailsScale {
    float get ();
    void set (float value);
}
Property Value
Type:   Online Single

            The thumbnails scale.

Exceptions
Exception | Condition
Online System Exception |
See Also
Settings Class
Settings Members


ThumbsGeneratedResult Class

ThumbsGeneratedResult Class Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
ThumbsGeneratedResult class
Inheritance Hierarchy
Online System Object
Conaito.PPT2HTML5 OperationResult
Conaito.PPT2HTML5 ThumbsGeneratedResult

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class ThumbsGeneratedResult : OperationResult
[SerializableAttribute]
public class ThumbsGeneratedResult : OperationResult
<SerializableAttribute>
Public Class ThumbsGeneratedResult
    Inherits OperationResult
<SerializableAttribute>
Public Class ThumbsGeneratedResult
    Inherits OperationResult
[SerializableAttribute]
public ref class ThumbsGeneratedResult : public OperationResult
[SerializableAttribute]
public ref class ThumbsGeneratedResult : public OperationResult
See Also
ThumbsGeneratedResult Members


ThumbsGeneratedResult Members

ThumbsGeneratedResult Members Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK

The ThumbsGeneratedResult type exposes the following members.
Properties
 | Name | Description
Public property | Thumbs | Gets the PowerPoint thumbs.
Back to Top
See Also
ThumbsGeneratedResult Class


ThumbsGeneratedResult Properties

ThumbsGeneratedResult Properties Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDKThe ThumbsGeneratedResult type exposes the following members.
Properties
 | Name | Description
Public property | Thumbs | Gets the PowerPoint thumbs.
Back to Top
See Also
ThumbsGeneratedResult Class


ThumbsGeneratedResult.Thumbs Property

ThumbsGeneratedResult Thumbs Property Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Gets the PowerPoint thumbs.

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public List<string> Thumbs { get; internal set; }
public List<string> Thumbs { get; internal set; }
Public Property Thumbs As List(Of String)
    Get
    Friend Set
Public Property Thumbs As List(Of String)
    Get
    Friend Set
public:
property List<String^>^ Thumbs {
    List<String^>^ get ();
    internal: void set (List<String^>^ value);
}
public:
property List<String^>^ Thumbs {
    List<String^>^ get ();
    internal: void set (List<String^>^ value);
}
Property Value
Type:   Online List    Online String

            The thumbs.

See Also
ThumbsGeneratedResult Class
ThumbsGeneratedResult Members


VideoFormat Enumeration

VideoFormat Enumeration Conaito PowerPoint-to-HTML5 SDK Documentation
Conaito PowerPoint-to-HTML5 SDK
Represents HTML 5 video format enumeration

Namespace: Conaito.PPT2HTML5
Assembly: Conaito.PPT2HTML5 (in Conaito.PPT2HTML5.dll) Version: 1.2.4884.38018 (1.2.*)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum VideoFormat
public enum VideoFormat
Public Enumeration VideoFormat
Public Enumeration VideoFormat
public enum class VideoFormat
public enum class VideoFormat
Members
Member name | Value | Description
MP4 | 0 | H.264/MPEG-4 AVC video format, supported in IE 9+, Chrome 6+, Safari 5+
OggTheora | 1 | The Ogg Theora video format, supported in Chrome 6+, Opera 10.6+, Firefox 3.6+
WebM | 2 | The WebM video format, supported in Chrome 6+, Opera 10.6+, Firefox 4+
See Also