Conaito.SWFSlideShow Namespace

[image]

conaito SlideShow SDK v1.6 Documentation
Conaito.SWFSlideShow Namespace
Send Feedback
conaito SlideShow SDK v1.6
conaito SlideShow SDK

Classes

 | Class | Description
Public class | SlideShow | Core class for generating SWF SlideShow

Enumerations

 | Enumeration | Description
Public enumeration | NavigationPanelAlignment | NavigationpanelAlignment Enumeration
Public enumeration | SizeMode | SizeModeType Enumeration
Public enumeration | TransitionEffect | SlideTransitionEffectType Enumeration
conaito SlideShow SDK v1.6

Send comments on this topic to support@conaito.com

Copyright © conaito Technologies 2011


NavigationPanelAlignment Enumeration

[image]

conaito SlideShow SDK v1.6 Documentation
NavigationPanelAlignment Enumeration
See Also Send Feedback
conaito SlideShow SDK v1.6
NavigationpanelAlignment Enumeration

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public enum NavigationPanelAlignment
Visual Basic
Public Enumeration NavigationPanelAlignment
Visual C++
public enum class NavigationPanelAlignment

Members

Member name | Description
Left |
Center |
Right |

See Also

Conaito.SWFSlideShow Namespace


SizeMode Enumeration

[image]

conaito SlideShow SDK v1.6 Documentation
SizeMode Enumeration
See Also Send Feedback
conaito SlideShow SDK v1.6
SizeModeType Enumeration

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public enum SizeMode
Visual Basic
Public Enumeration SizeMode
Visual C++
public enum class SizeMode

Members

Member name | Description
Repeat |
Stretch |
Center |

See Also

Conaito.SWFSlideShow Namespace
conaito SlideShow SDK v1.6

Send comments on this topic to support@conaito.com

Copyright © conaito Technologies 2011


SlideShow Class

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow Class
Members See Also Send Feedback
conaito SlideShow SDK v1.6
Core class for generating SWF SlideShow

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public class SlideShow
Visual Basic
Public Class SlideShow
Visual C++
public ref class SlideShow

Inheritance Hierarchy

System..::..Object
Conaito.SWFSlideShow..::..SlideShow

See Also

SlideShow Members


SlideShow Members

[image] [image]

conaito SlideShow SDK v1.6 Documentation
SlideShow Members
SlideShow Class Constructors Methods Properties See Also Send Feedback
conaito SlideShow SDK v1.6

The SlideShow type exposes the following members.

Constructors

 | Name | Description
Public method | SlideShow | Constructor

Methods

 | Name | Description
Public method | AddSlideFromFile(Image, TransitionEffect, Int32) | Use this method to add slides from image(BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(String, TransitionEffect, Int32) | Use this method to add slides from image files (BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(Image, TransitionEffect, Int32, SizeMode) | Use this method to add slides from image(BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(String, TransitionEffect, Int32, SizeMode) | Use this method to add slides from image files (BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(Image, TransitionEffect, Int32, SizeMode, RotateFlipType) | Use this method to add slides from image(BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(String, TransitionEffect, Int32, SizeMode, RotateFlipType) | Use this method to add slides from image files (BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(Image, TransitionEffect, Int32, SizeMode, RotateFlipType, Int32, Int32) | Use this method to add slides from image (BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(String, TransitionEffect, Int32, SizeMode, RotateFlipType, Int32, Int32) | Use this method to add slides from image files (BMP, JPG,PNG,GIF,TIFF are supported)
Public method | ClearTempDirectory | Clear temp directory. Use after methods "SaveToFile", "SaveToFileAsExe" or "GetBinaryImage" if you used method"GetSlidesFromPPT"
Public method | ConvertEXE2SWF | Converting EXE to SWF. SWF can be extracted in case the exe-file is Macromedia Projector only.
Public method | ConvertSWF2EXE | Converting SWF to EXE. FlashPlayer.exe must be contains in assembly directory
Public method | GetAllEffects | Return all Transitions Effect as string array
Public method | GetAssemblyDirectory | Get Assembly Directory
Public method | GetBinaryImage | Returns generated Flash movie as byte array for use with ASP.NET to implement *on-the-fly*
Public method | GetLibraryVersion | Returns version of the library
Public method | GetLicenseInfo | Gets the license info.
Public method | GetRandomTransitionEffect | Returns *random* slide transition effect type
Public method | GetSlidesFromPPT | Get slides from PowerPoint file
Public method | IsLicenseValid | Determines whether [is license valid].
Public method | Pause | Use this method to add pause before next slide
Public method | SaveToFile | Saves generated flash slide show to the file
Public method | SaveToFileAsExe | Saves generated flash slide show to the file as EXE
Public method | SetBackgroundColor | Use this method to set background color for the slide show
Public method | SetBackgroundImage | Use this method to set background Image for the slide show
Public method | SetBackgroundSound | This method sets background soundtrack from audio file mp3 for the generated slideshow
Public method | SetLicense | Initializes license information
Public method | Start | Starts slideshow generation with desired output movie width and height
Public method | WaitForClick | Show next slide after click on SlideShow

Properties

 | Name | Description
Public property | FPS | Property controls FPS (frames-per-second) value of generated flash slideshow
Public property | LoopBackgroundSound | Loop background sound. Default value - true;
Public property | NavigationPanelAlignment | Set navigation panel alignment
Public property | NavigationPanelOffset | Set offset in pixels to Navigation Panel from bottom of slideshow
Public property | PreloaderColor | Preloader color
Public property | PreloaderFontColor | Preloader font color
Public property | ShowNavigationPanel | Show navigation Panel
Public property | ShowPreloader | Show SlideShow preloader
Public property | TempDirectory | Temp directory for exporting slides to images from ppt files

See Also

SlideShow Class


SlideShow Constructor

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow Constructor
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Constructor

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public SlideShow()
Visual Basic
Public Sub New
Visual C++
public:
SlideShow()

See Also


SlideShow Methods

[image] [image]

conaito SlideShow SDK v1.6 Documentation
SlideShow Methods
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6

The SlideShow type exposes the following members.

Methods

 | Name | Description
Public method | AddSlideFromFile(Image, TransitionEffect, Int32) | Use this method to add slides from image(BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(String, TransitionEffect, Int32) | Use this method to add slides from image files (BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(Image, TransitionEffect, Int32, SizeMode) | Use this method to add slides from image(BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(String, TransitionEffect, Int32, SizeMode) | Use this method to add slides from image files (BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(Image, TransitionEffect, Int32, SizeMode, RotateFlipType) | Use this method to add slides from image(BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(String, TransitionEffect, Int32, SizeMode, RotateFlipType) | Use this method to add slides from image files (BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(Image, TransitionEffect, Int32, SizeMode, RotateFlipType, Int32, Int32) | Use this method to add slides from image (BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(String, TransitionEffect, Int32, SizeMode, RotateFlipType, Int32, Int32) | Use this method to add slides from image files (BMP, JPG,PNG,GIF,TIFF are supported)
Public method | ClearTempDirectory | Clear temp directory. Use after methods "SaveToFile", "SaveToFileAsExe" or "GetBinaryImage" if you used method"GetSlidesFromPPT"
Public method | ConvertEXE2SWF | Converting EXE to SWF. SWF can be extracted in case the exe-file is Macromedia Projector only.
Public method | ConvertSWF2EXE | Converting SWF to EXE. FlashPlayer.exe must be contains in assembly directory
Public method | GetAllEffects | Return all Transitions Effect as string array
Public method | GetAssemblyDirectory | Get Assembly Directory
Public method | GetBinaryImage | Returns generated Flash movie as byte array for use with ASP.NET to implement *on-the-fly*
Public method | GetLibraryVersion | Returns version of the library
Public method | GetLicenseInfo | Gets the license info.
Public method | GetRandomTransitionEffect | Returns *random* slide transition effect type
Public method | GetSlidesFromPPT | Get slides from PowerPoint file
Public method | IsLicenseValid | Determines whether [is license valid].
Public method | Pause | Use this method to add pause before next slide
Public method | SaveToFile | Saves generated flash slide show to the file
Public method | SaveToFileAsExe | Saves generated flash slide show to the file as EXE
Public method | SetBackgroundColor | Use this method to set background color for the slide show
Public method | SetBackgroundImage | Use this method to set background Image for the slide show
Public method | SetBackgroundSound | This method sets background soundtrack from audio file mp3 for the generated slideshow
Public method | SetLicense | Initializes license information
Public method | Start | Starts slideshow generation with desired output movie width and height
Public method | WaitForClick | Show next slide after click on SlideShow

See Also


AddSlideFromFile Method

[image] [image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..AddSlideFromFile Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6

Overload List

 | Name | Description
Public method | AddSlideFromFile(Image, TransitionEffect, Int32) | Use this method to add slides from image(BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(String, TransitionEffect, Int32) | Use this method to add slides from image files (BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(Image, TransitionEffect, Int32, SizeMode) | Use this method to add slides from image(BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(String, TransitionEffect, Int32, SizeMode) | Use this method to add slides from image files (BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(Image, TransitionEffect, Int32, SizeMode, RotateFlipType) | Use this method to add slides from image(BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(String, TransitionEffect, Int32, SizeMode, RotateFlipType) | Use this method to add slides from image files (BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(Image, TransitionEffect, Int32, SizeMode, RotateFlipType, Int32, Int32) | Use this method to add slides from image (BMP, JPG,PNG,GIF,TIFF are supported)
Public method | AddSlideFromFile(String, TransitionEffect, Int32, SizeMode, RotateFlipType, Int32, Int32) | Use this method to add slides from image files (BMP, JPG,PNG,GIF,TIFF are supported)

See Also

SlideShow Members


AddSlideFromFile Method (Image, TransitionEffect, Int32)

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..AddSlideFromFile Method (Image, TransitionEffect, Int32)
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Use this method to add slides from image(BMP, JPG,PNG,GIF,TIFF are supported)

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void AddSlideFromFile(
    Image image,
    TransitionEffect effect,
    int durationSec
)
Visual Basic
Public Sub AddSlideFromFile ( _
    image As Image, _
    effect As TransitionEffect, _
    durationSec As Integer _
)
Visual C++
public:
void AddSlideFromFile(
    Image^ image,
    TransitionEffect effect,
    int durationSec
)

Parameters

image
Type: System.Drawing..::..Image
image
effect
Type: Conaito.SWFSlideShow..::..TransitionEffect
slide transition effect
durationSec
Type: System..::..Int32
durations in seconds

See Also

AddSlideFromFile Overload


AddSlideFromFile Method (String, TransitionEffect, Int32)

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..AddSlideFromFile Method (String, TransitionEffect, Int32)
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Use this method to add slides from image files (BMP, JPG,PNG,GIF,TIFF are supported)

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void AddSlideFromFile(
    string filePath,
    TransitionEffect effect,
    int durationSec
)
Visual Basic
Public Sub AddSlideFromFile ( _
    filePath As String, _
    effect As TransitionEffect, _
    durationSec As Integer _
)
Visual C++
public:
void AddSlideFromFile(
    String^ filePath,
    TransitionEffect effect,
    int durationSec
)

Parameters

filePath
Type: System..::..String
path to image file
effect
Type: Conaito.SWFSlideShow..::..TransitionEffect
slide transition effect
durationSec
Type: System..::..Int32
durations in seconds

See Also

AddSlideFromFile Overload


AddSlideFromFile Method (Image, TransitionEffect, Int32, SizeMode)

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..AddSlideFromFile Method (Image, TransitionEffect, Int32, SizeMode)
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Use this method to add slides from image(BMP, JPG,PNG,GIF,TIFF are supported)

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void AddSlideFromFile(
    Image image,
    TransitionEffect effect,
    int durationSec,
    SizeMode sizeMode
)
Visual Basic
Public Sub AddSlideFromFile ( _
    image As Image, _
    effect As TransitionEffect, _
    durationSec As Integer, _
    sizeMode As SizeMode _
)
Visual C++
public:
void AddSlideFromFile(
    Image^ image,
    TransitionEffect effect,
    int durationSec,
    SizeMode sizeMode
)

Parameters

image
Type: System.Drawing..::..Image
image
effect
Type: Conaito.SWFSlideShow..::..TransitionEffect
slide transition effect
durationSec
Type: System..::..Int32
durations in seconds
sizeMode
Type: Conaito.SWFSlideShow..::..SizeMode
size mode of image

See Also

AddSlideFromFile Overload


AddSlideFromFile Method (String, TransitionEffect, Int32, SizeMode)

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..AddSlideFromFile Method (String, TransitionEffect, Int32, SizeMode)
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Use this method to add slides from image files (BMP, JPG,PNG,GIF,TIFF are supported)

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void AddSlideFromFile(
    string filePath,
    TransitionEffect effect,
    int durationSec,
    SizeMode sizeMode
)
Visual Basic
Public Sub AddSlideFromFile ( _
    filePath As String, _
    effect As TransitionEffect, _
    durationSec As Integer, _
    sizeMode As SizeMode _
)
Visual C++
public:
void AddSlideFromFile(
    String^ filePath,
    TransitionEffect effect,
    int durationSec,
    SizeMode sizeMode
)

Parameters

filePath
Type: System..::..String
path to image file
effect
Type: Conaito.SWFSlideShow..::..TransitionEffect
slide transition effect
durationSec
Type: System..::..Int32
durations in seconds
sizeMode
Type: Conaito.SWFSlideShow..::..SizeMode
size mode of image

See Also

AddSlideFromFile Overload


AddSlideFromFile Method (Image, TransitionEffect, Int32, SizeMode, RotateFlipType)

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..AddSlideFromFile Method (Image, TransitionEffect, Int32, SizeMode, RotateFlipType)
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Use this method to add slides from image(BMP, JPG,PNG,GIF,TIFF are supported)

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void AddSlideFromFile(
    Image image,
    TransitionEffect effect,
    int durationSec,
    SizeMode sizeMode,
    RotateFlipType rotateAndFlip
)
Visual Basic
Public Sub AddSlideFromFile ( _
    image As Image, _
    effect As TransitionEffect, _
    durationSec As Integer, _
    sizeMode As SizeMode, _
    rotateAndFlip As RotateFlipType _
)
Visual C++
public:
void AddSlideFromFile(
    Image^ image,
    TransitionEffect effect,
    int durationSec,
    SizeMode sizeMode,
    RotateFlipType rotateAndFlip
)

Parameters

image
Type: System.Drawing..::..Image
image
effect
Type: Conaito.SWFSlideShow..::..TransitionEffect
slide transition effect
durationSec
Type: System..::..Int32
durations in seconds
sizeMode
Type: Conaito.SWFSlideShow..::..SizeMode
size mode of image
rotateAndFlip
Type: System.Drawing..::..RotateFlipType
rotate and flip

See Also

AddSlideFromFile Overload


AddSlideFromFile Method (String, TransitionEffect, Int32, SizeMode, RotateFlipType)

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..AddSlideFromFile Method (String, TransitionEffect, Int32, SizeMode, RotateFlipType)
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Use this method to add slides from image files (BMP, JPG,PNG,GIF,TIFF are supported)

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void AddSlideFromFile(
    string filePath,
    TransitionEffect effect,
    int durationSec,
    SizeMode sizeMode,
    RotateFlipType rotateAndFlip
)
Visual Basic
Public Sub AddSlideFromFile ( _
    filePath As String, _
    effect As TransitionEffect, _
    durationSec As Integer, _
    sizeMode As SizeMode, _
    rotateAndFlip As RotateFlipType _
)
Visual C++
public:
void AddSlideFromFile(
    String^ filePath,
    TransitionEffect effect,
    int durationSec,
    SizeMode sizeMode,
    RotateFlipType rotateAndFlip
)

Parameters

filePath
Type: System..::..String
path to image file
effect
Type: Conaito.SWFSlideShow..::..TransitionEffect
slide transition effect
durationSec
Type: System..::..Int32
durations in seconds
sizeMode
Type: Conaito.SWFSlideShow..::..SizeMode
size mode of image
rotateAndFlip
Type: System.Drawing..::..RotateFlipType
rotate and flip

See Also

AddSlideFromFile Overload


AddSlideFromFile Method (Image, TransitionEffect, Int32, SizeMode, RotateFlipType, Int32, Int32)

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..AddSlideFromFile Method (Image, TransitionEffect, Int32, SizeMode, RotateFlipType, Int32, Int32)
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Use this method to add slides from image (BMP, JPG,PNG,GIF,TIFF are supported)

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void AddSlideFromFile(
    Image image,
    TransitionEffect effect,
    int durationSec,
    SizeMode sizeMode,
    RotateFlipType rotateAndFlip,
    int width,
    int height
)
Visual Basic
Public Sub AddSlideFromFile ( _
    image As Image, _
    effect As TransitionEffect, _
    durationSec As Integer, _
    sizeMode As SizeMode, _
    rotateAndFlip As RotateFlipType, _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
void AddSlideFromFile(
    Image^ image,
    TransitionEffect effect,
    int durationSec,
    SizeMode sizeMode,
    RotateFlipType rotateAndFlip,
    int width,
    int height
)

Parameters

image
Type: System.Drawing..::..Image
image
effect
Type: Conaito.SWFSlideShow..::..TransitionEffect
slide transition effect
durationSec
Type: System..::..Int32
durations in seconds
sizeMode
Type: Conaito.SWFSlideShow..::..SizeMode
size mode of image
rotateAndFlip
Type: System.Drawing..::..RotateFlipType
rotate and flip
width
Type: System..::..Int32
width
height
Type: System..::..Int32
height

See Also

AddSlideFromFile Overload


AddSlideFromFile Method (String, TransitionEffect, Int32, SizeMode, RotateFlipType, Int32, Int32)

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..AddSlideFromFile Method (String, TransitionEffect, Int32, SizeMode, RotateFlipType, Int32, Int32)
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Use this method to add slides from image files (BMP, JPG,PNG,GIF,TIFF are supported)

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void AddSlideFromFile(
    string filePath,
    TransitionEffect effect,
    int durationSec,
    SizeMode sizeMode,
    RotateFlipType rotateAndFlip,
    int width,
    int height
)
Visual Basic
Public Sub AddSlideFromFile ( _
    filePath As String, _
    effect As TransitionEffect, _
    durationSec As Integer, _
    sizeMode As SizeMode, _
    rotateAndFlip As RotateFlipType, _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
void AddSlideFromFile(
    String^ filePath,
    TransitionEffect effect,
    int durationSec,
    SizeMode sizeMode,
    RotateFlipType rotateAndFlip,
    int width,
    int height
)

Parameters

filePath
Type: System..::..String
path to image file
effect
Type: Conaito.SWFSlideShow..::..TransitionEffect
slide transition effect
durationSec
Type: System..::..Int32
durations in seconds
sizeMode
Type: Conaito.SWFSlideShow..::..SizeMode
size mode of image
rotateAndFlip
Type: System.Drawing..::..RotateFlipType
rotate and flip
width
Type: System..::..Int32
width
height
Type: System..::..Int32
height

See Also

AddSlideFromFile Overload


ClearTempDirectory Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..ClearTempDirectory Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Clear temp directory. Use after methods "SaveToFile", "SaveToFileAsExe" or "GetBinaryImage" if you used method"GetSlidesFromPPT"

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void ClearTempDirectory()
Visual Basic
Public Sub ClearTempDirectory
Visual C++
public:
void ClearTempDirectory()

See Also


ConvertEXE2SWF Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..ConvertEXE2SWF Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Converting EXE to SWF. SWF can be extracted in case the exe-file is Macromedia Projector only.

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void ConvertEXE2SWF(
    string exeFilePath,
    string swfFilePath
)
Visual Basic
Public Sub ConvertEXE2SWF ( _
    exeFilePath As String, _
    swfFilePath As String _
)
Visual C++
public:
void ConvertEXE2SWF(
    String^ exeFilePath,
    String^ swfFilePath
)

Parameters

exeFilePath
Type: System..::..String
exe file path
swfFilePath
Type: System..::..String
swf file path

See Also


ConvertSWF2EXE Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..ConvertSWF2EXE Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Converting SWF to EXE. FlashPlayer.exe must be contains in assembly directory

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void ConvertSWF2EXE(
    string swfFilePath,
    string exeFilePath
)
Visual Basic
Public Sub ConvertSWF2EXE ( _
    swfFilePath As String, _
    exeFilePath As String _
)
Visual C++
public:
void ConvertSWF2EXE(
    String^ swfFilePath,
    String^ exeFilePath
)

Parameters

swfFilePath
Type: System..::..String
swf file path
exeFilePath
Type: System..::..String
exe file path

See Also


GetAllEffects Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..GetAllEffects Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Return all Transitions Effect as string array

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public string[] GetAllEffects()
Visual Basic
Public Function GetAllEffects As String()
Visual C++
public:
array<String^>^ GetAllEffects()

Return Value

See Also


GetAssemblyDirectory Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..GetAssemblyDirectory Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Get Assembly Directory

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public string GetAssemblyDirectory()
Visual Basic
Public Function GetAssemblyDirectory As String
Visual C++
public:
String^ GetAssemblyDirectory()

Return Value

See Also


GetBinaryImage Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..GetBinaryImage Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Returns generated Flash movie as byte array for use with ASP.NET to implement *on-the-fly*

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public byte[] GetBinaryImage()
Visual Basic
Public Function GetBinaryImage As Byte()
Visual C++
public:
array<unsigned char>^ GetBinaryImage()

Return Value

See Also


GetLibraryVersion Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..GetLibraryVersion Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Returns version of the library

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public string GetLibraryVersion()
Visual Basic
Public Function GetLibraryVersion As String
Visual C++
public:
String^ GetLibraryVersion()

Return Value

See Also


GetLicenseInfo Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..GetLicenseInfo Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Gets the license info.

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public string GetLicenseInfo()
Visual Basic
Public Function GetLicenseInfo As String
Visual C++
public:
String^ GetLicenseInfo()

Return Value

See Also


GetRandomTransitionEffect Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..GetRandomTransitionEffect Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Returns *random* slide transition effect type

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public TransitionEffect GetRandomTransitionEffect()
Visual Basic
Public Function GetRandomTransitionEffect As TransitionEffect
Visual C++
public:
TransitionEffect GetRandomTransitionEffect()

Return Value

See Also


GetSlidesFromPPT Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..GetSlidesFromPPT Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Get slides from PowerPoint file

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public Image[] GetSlidesFromPPT(
    string pptFile
)
Visual Basic
Public Function GetSlidesFromPPT ( _
    pptFile As String _
) As Image()
Visual C++
public:
array<Image^>^ GetSlidesFromPPT(
    String^ pptFile
)

Parameters

pptFile
Type: System..::..String
PowerPoint file path

Return Value

array of path to images

See Also


IsLicenseValid Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..IsLicenseValid Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Determines whether [is license valid].

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public bool IsLicenseValid()
Visual Basic
Public Function IsLicenseValid As Boolean
Visual C++
public:
bool IsLicenseValid()

Return Value

true if [is license valid]; otherwise, false.

See Also


Pause Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..Pause Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Use this method to add pause before next slide

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void Pause(
    int seconds
)
Visual Basic
Public Sub Pause ( _
    seconds As Integer _
)
Visual C++
public:
void Pause(
    int seconds
)

Parameters

seconds
Type: System..::..Int32

See Also


SaveToFile Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..SaveToFile Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Saves generated flash slide show to the file

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void SaveToFile(
    string swfFilePath
)
Visual Basic
Public Sub SaveToFile ( _
    swfFilePath As String _
)
Visual C++
public:
void SaveToFile(
    String^ swfFilePath
)

Parameters

swfFilePath
Type: System..::..String
path to swf file

See Also


SaveToFileAsExe Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..SaveToFileAsExe Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Saves generated flash slide show to the file as EXE

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void SaveToFileAsExe(
    string exeFilePath
)
Visual Basic
Public Sub SaveToFileAsExe ( _
    exeFilePath As String _
)
Visual C++
public:
void SaveToFileAsExe(
    String^ exeFilePath
)

Parameters

exeFilePath
Type: System..::..String
path to exe file

See Also


SetBackgroundColor Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..SetBackgroundColor Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Use this method to set background color for the slide show

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void SetBackgroundColor(
    Color color
)
Visual Basic
Public Sub SetBackgroundColor ( _
    color As Color _
)
Visual C++
public:
void SetBackgroundColor(
    Color color
)

Parameters

color
Type: System.Drawing..::..Color
color for background

See Also


SetBackgroundImage Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..SetBackgroundImage Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Use this method to set background Image for the slide show

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void SetBackgroundImage(
    string imagePath
)
Visual Basic
Public Sub SetBackgroundImage ( _
    imagePath As String _
)
Visual C++
public:
void SetBackgroundImage(
    String^ imagePath
)

Parameters

imagePath
Type: System..::..String
Path to background image

See Also


SetBackgroundSound Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..SetBackgroundSound Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
This method sets background soundtrack from audio file mp3 for the generated slideshow

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void SetBackgroundSound(
    string filePath
)
Visual Basic
Public Sub SetBackgroundSound ( _
    filePath As String _
)
Visual C++
public:
void SetBackgroundSound(
    String^ filePath
)

Parameters

filePath
Type: System..::..String

See Also


SetLicense Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..SetLicense Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Initializes license information

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void SetLicense(
    string licenseKey
)
Visual Basic
Public Sub SetLicense ( _
    licenseKey As String _
)
Visual C++
public:
void SetLicense(
    String^ licenseKey
)

Parameters

licenseKey
Type: System..::..String
The license key.

See Also


Start Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..Start Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Starts slideshow generation with desired output movie width and height

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void Start(
    int width,
    int height
)
Visual Basic
Public Sub Start ( _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
void Start(
    int width,
    int height
)

Parameters

width
Type: System..::..Int32
SlideShow width
height
Type: System..::..Int32
SlideShow height

See Also


WaitForClick Method

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..WaitForClick Method
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Show next slide after click on SlideShow

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public void WaitForClick()
Visual Basic
Public Sub WaitForClick
Visual C++
public:
void WaitForClick()

See Also


SlideShow Properties

[image] [image]

conaito SlideShow SDK v1.6 Documentation
SlideShow Properties
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6

The SlideShow type exposes the following members.

Properties

 | Name | Description
Public property | FPS | Property controls FPS (frames-per-second) value of generated flash slideshow
Public property | LoopBackgroundSound | Loop background sound. Default value - true;
Public property | NavigationPanelAlignment | Set navigation panel alignment
Public property | NavigationPanelOffset | Set offset in pixels to Navigation Panel from bottom of slideshow
Public property | PreloaderColor | Preloader color
Public property | PreloaderFontColor | Preloader font color
Public property | ShowNavigationPanel | Show navigation Panel
Public property | ShowPreloader | Show SlideShow preloader
Public property | TempDirectory | Temp directory for exporting slides to images from ppt files

See Also


FPS Property

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..FPS Property
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Property controls FPS (frames-per-second) value of generated flash slideshow

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public int FPS { get; set; }
Visual Basic
Public Property FPS As Integer
    Get
    Set
Visual C++
public:
property int FPS {
    int get ();
    void set (int value);
}

See Also


LoopBackgroundSound Property

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..LoopBackgroundSound Property
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Loop background sound. Default value - true;

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public bool LoopBackgroundSound { get; set; }
Visual Basic
Public Property LoopBackgroundSound As Boolean
    Get
    Set
Visual C++
public:
property bool LoopBackgroundSound {
    bool get ();
    void set (bool value);
}

See Also


NavigationPanelAlignment Property

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..NavigationPanelAlignment Property
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Set navigation panel alignment

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public NavigationPanelAlignment NavigationPanelAlignment { get; set; }
Visual Basic
Public Property NavigationPanelAlignment As NavigationPanelAlignment
    Get
    Set
Visual C++
public:
property NavigationPanelAlignment NavigationPanelAlignment {
    NavigationPanelAlignment get ();
    void set (NavigationPanelAlignment value);
}

See Also


NavigationPanelOffset Property

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..NavigationPanelOffset Property
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Set offset in pixels to Navigation Panel from bottom of slideshow

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public int NavigationPanelOffset { get; set; }
Visual Basic
Public Property NavigationPanelOffset As Integer
    Get
    Set
Visual C++
public:
property int NavigationPanelOffset {
    int get ();
    void set (int value);
}

See Also


PreloaderColor Property

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..PreloaderColor Property
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Preloader color

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public Color PreloaderColor { get; set; }
Visual Basic
Public Property PreloaderColor As Color
    Get
    Set
Visual C++
public:
property Color PreloaderColor {
    Color get ();
    void set (Color value);
}

See Also


PreloaderFontColor Property

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..PreloaderFontColor Property
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Preloader font color

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public Color PreloaderFontColor { get; set; }
Visual Basic
Public Property PreloaderFontColor As Color
    Get
    Set
Visual C++
public:
property Color PreloaderFontColor {
    Color get ();
    void set (Color value);
}

See Also


ShowNavigationPanel Property

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..ShowNavigationPanel Property
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Show navigation Panel

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public bool ShowNavigationPanel { get; set; }
Visual Basic
Public Property ShowNavigationPanel As Boolean
    Get
    Set
Visual C++
public:
property bool ShowNavigationPanel {
    bool get ();
    void set (bool value);
}

See Also


ShowPreloader Property

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..ShowPreloader Property
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Show SlideShow preloader

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public bool ShowPreloader { get; set; }
Visual Basic
Public Property ShowPreloader As Boolean
    Get
    Set
Visual C++
public:
property bool ShowPreloader {
    bool get ();
    void set (bool value);
}

See Also


TempDirectory Property

[image]

conaito SlideShow SDK v1.6 Documentation
SlideShow..::..TempDirectory Property
SlideShow Class See Also Send Feedback
conaito SlideShow SDK v1.6
Temp directory for exporting slides to images from ppt files

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public string TempDirectory { get; }
Visual Basic
Public ReadOnly Property TempDirectory As String
    Get
Visual C++
public:
property String^ TempDirectory {
    String^ get ();
}

See Also


TransitionEffect Enumeration

[image]

conaito SlideShow SDK v1.6 Documentation
TransitionEffect Enumeration
See Also Send Feedback
conaito SlideShow SDK v1.6
SlideTransitionEffectType Enumeration

Namespace: Conaito.SWFSlideShow
Assembly: Conaito.SWFSlideShow (in Conaito.SWFSlideShow.dll) Version: 1.6.0.0 (1.6.0.0)

Syntax

C#
public enum TransitionEffect
Visual Basic
Public Enumeration TransitionEffect
Visual C++
public enum class TransitionEffect

Members

Member name | Description
None |
Newsflash |
FadeSmoothly |
CutThroughBlack |
CoverLeft |
CoverLeftDown |
CoverLeftUp |
CoverRight |
CoverRightDown |
CoverRightUp |
CoverUp |
CoverDown |
PushDown |
PushLeft |
PushRight |
PushUp |
UncoverDown |
UncoverLeft |
UncoverLeftDown |
UncoverLeftUp |
UncoverRight |
UncoverRightDown |
UncoverRightUp |
UncoverUp |
ZoomFromRight |
ZoomFromRightCenter |
ZoomFromLeft |
ZoomFromLeftCenter |
ZoomFromTop |
ZoomFromTopCenter |
ZoomFromBottom |
ZoomFromBottomCenter |
ZoomFromRightTop |
ZoomFromRightBottom |
ZoomFromLeftBottom |
ZoomFromLeftTop |
ZoomFromCenter |
ZoomFromCenterHorizontal |
ZoomFromCenterVertical |
WipeLeft |
WipeDown |
Clip |

See Also

Conaito.SWFSlideShow Namespace
conaito SlideShow SDK v1.6

Send comments on this topic to support@conaito.com

Copyright © conaito Technologies 2011