Conaito.XPS2Image

conaito XPS2Image SDK 1.0

Conaito.XPS2Image Namespace

Namespace Hierarchy

Classes

Class | Description
ConvertingSettings |
XPSConverter |
XPSDocumentInfo |

Enumerations

Enumeration | Description
ImageFormat |
ImageQuality |

Send comments on this topic.

© conaito Technologies 2009


ConvertingSettings Class

For a list of all members of this type, see ConvertingSettings Members .

System.Object
ConvertingSettings

[Visual Basic]
Public Class ConvertingSettings
[C#]
public class ConvertingSettings

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.XPS2Image

Assembly: Conaito.XPS2Image (in Conaito.XPS2Image.dll)

See Also

ConvertingSettings Members | Conaito.XPS2Image Namespace


ConvertingSettings Members

ConvertingSettings overview

Public Instance Properties

GenerateXML | Generate "slideshow.xml" file
ImageFormat | Image format
ImagePrefix | Image prefix, default - "page_"
ImageQuality | Image quality

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ConvertingSettings Class | Conaito.XPS2Image Namespace


ConvertingSettings Properties

The properties of the ConvertingSettings class are listed below. For a complete list of ConvertingSettings class members, see the ConvertingSettings Members topic.

Public Instance Properties

GenerateXML | Generate "slideshow.xml" file
ImageFormat | Image format
ImagePrefix | Image prefix, default - "page_"
ImageQuality | Image quality

See Also

ConvertingSettings Class | Conaito.XPS2Image Namespace


GenerateXML Property

conaito XPS2Image SDK 1.0

ConvertingSettings.GenerateXML Property

Generate "slideshow.xml" file

[Visual Basic]
Public Property GenerateXML() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool GenerateXML { public get; public set; }

See Also

ConvertingSettings Class | Conaito.XPS2Image Namespace


ImageFormat Property

conaito XPS2Image SDK 1.0

ConvertingSettings.ImageFormat Property

Image format

[Visual Basic]
Public Property ImageFormat() As ImageFormat
Public Get
End Get
Public Set
End Set
End Property
[C#]
public ImageFormat ImageFormat { public get; public set; }

See Also

ConvertingSettings Class | Conaito.XPS2Image Namespace


ImagePrefix Property

conaito XPS2Image SDK 1.0

ConvertingSettings.ImagePrefix Property

Image prefix, default - "page_"

[Visual Basic]
Public Property ImagePrefix() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
public string ImagePrefix { public get; public set; }

See Also

ConvertingSettings Class | Conaito.XPS2Image Namespace


ImageQuality Property

conaito XPS2Image SDK 1.0

ConvertingSettings.ImageQuality Property

Image quality

[Visual Basic]
Public Property ImageQuality() As ImageQuality
Public Get
End Get
Public Set
End Set
End Property
[C#]
public ImageQuality ImageQuality { public get; public set; }

See Also

ConvertingSettings Class | Conaito.XPS2Image Namespace


ImageFormat Enumeration

[Visual Basic]
Public Enum ImageFormat
[C#]
public enum ImageFormat

Members

Member Name | Description
Jpeg |
Png |
Gif |

Requirements

Namespace: Conaito.XPS2Image

Assembly: Conaito.XPS2Image (in Conaito.XPS2Image.dll)

See Also

Conaito.XPS2Image Namespace


ImageQuality Enumeration

[Visual Basic]
Public Enum ImageQuality
[C#]
public enum ImageQuality

Members

Member Name | Description
Low |
Normal |
Highly |

Requirements

Namespace: Conaito.XPS2Image

Assembly: Conaito.XPS2Image (in Conaito.XPS2Image.dll)

See Also

Conaito.XPS2Image Namespace


XPSConverter Class

For a list of all members of this type, see XPSConverter Members .

System.Object
XPSConverter

[Visual Basic]
Public Class XPSConverter
[C#]
public class XPSConverter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.XPS2Image

Assembly: Conaito.XPS2Image (in Conaito.XPS2Image.dll)

See Also

XPSConverter Members | Conaito.XPS2Image Namespace


XPSConverter Members

XPSConverter overview

Public Instance Constructors

XPSConverter Constructor Initializes a new instance of the XPSConverter class.

Public Instance Properties

Settings | Convertion settings
XPSDocumentInfo | XPS document information

Public Instance Methods

ConvertToImage | Convert to image
CopyPlayer | Copy slideshow flash player
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
OpenXPSDocument | Open xps document
SetLicense | Set license name and key
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

XPSConverter Class | Conaito.XPS2Image Namespace


XPSConverter Constructor

Initializes a new instance of the XPSConverter class.

[Visual Basic]
Public Sub New()
[C#]
XPSConverter();

See Also

XPSConverter Class | Conaito.XPS2Image Namespace


XPSConverter Properties

The properties of the XPSConverter class are listed below. For a complete list of XPSConverter class members, see the XPSConverter Members topic.

Public Instance Properties

Settings | Convertion settings
XPSDocumentInfo | XPS document information

See Also

XPSConverter Class | Conaito.XPS2Image Namespace


Settings Property

conaito XPS2Image SDK 1.0

XPSConverter.Settings Property

Convertion settings

[Visual Basic]
Public Property Settings() As ConvertingSettings
Public Get
End Get
Private Set
End Set
End Property
[C#]
public ConvertingSettings Settings { public get; private set; }

See Also

XPSConverter Class | Conaito.XPS2Image Namespace


XPSDocumentInfo Property

conaito XPS2Image SDK 1.0

XPSConverter.XPSDocumentInfo Property

XPS document information

[Visual Basic]
Public Property XPSDocumentInfo() As XPSDocumentInfo
Public Get
End Get
Private Set
End Set
End Property
[C#]
public XPSDocumentInfo XPSDocumentInfo { public get; private set; }

See Also

XPSConverter Class | Conaito.XPS2Image Namespace


XPSConverter Methods

The methods of the XPSConverter class are listed below. For a complete list of XPSConverter class members, see the XPSConverter Members topic.

Public Instance Methods

ConvertToImage | Convert to image
CopyPlayer | Copy slideshow flash player
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
OpenXPSDocument | Open xps document
SetLicense | Set license name and key
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

XPSConverter Class | Conaito.XPS2Image Namespace


XPSConverter.ConvertToImage Method

Convert to image

[Visual Basic]
Public Sub ConvertToImage( _
ByVal outputFolder As String _
)
[C#]
public void ConvertToImage(
string outputFolder
);

Parameters

outputFolder

See Also

XPSConverter Class | Conaito.XPS2Image Namespace


XPSConverter.CopyPlayer Method

Copy slideshow flash player

[Visual Basic]
Public Sub CopyPlayer( _
ByVal destDir As String _
)
[C#]
public void CopyPlayer(
string destDir
);

Parameters

destDir

See Also

XPSConverter Class | Conaito.XPS2Image Namespace


XPSConverter.OpenXPSDocument Method

Open xps document

[Visual Basic]
Public Sub OpenXPSDocument( _
ByVal xpsFilePath As String _
)
[C#]
public void OpenXPSDocument(
string xpsFilePath
);

Parameters

xpsFilePath

See Also

XPSConverter Class | Conaito.XPS2Image Namespace


XPSConverter.SetLicense Method

Set license name and key

[Visual Basic]
Public Sub SetLicense( _
ByVal name As String, _
ByVal key As String _
)
[C#]
public void SetLicense(
string name,
string key
);

Parameters

name
key

See Also

XPSConverter Class | Conaito.XPS2Image Namespace


XPSDocumentInfo Class

For a list of all members of this type, see XPSDocumentInfo Members .

System.Object
XPSDocumentInfo

[Visual Basic]
Public Class XPSDocumentInfo
[C#]
public class XPSDocumentInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.XPS2Image

Assembly: Conaito.XPS2Image (in Conaito.XPS2Image.dll)

See Also

XPSDocumentInfo Members | Conaito.XPS2Image Namespace


XPSDocumentInfo Members

XPSDocumentInfo overview

Public Instance Properties

PagesCount | Pages count in xps document
Path | XPS file path

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

XPSDocumentInfo Class | Conaito.XPS2Image Namespace


XPSDocumentInfo Properties

The properties of the XPSDocumentInfo class are listed below. For a complete list of XPSDocumentInfo class members, see the XPSDocumentInfo Members topic.

Public Instance Properties

PagesCount | Pages count in xps document
Path | XPS file path

See Also

XPSDocumentInfo Class | Conaito.XPS2Image Namespace


PagesCount Property

conaito XPS2Image SDK 1.0

XPSDocumentInfo.PagesCount Property

Pages count in xps document

[Visual Basic]
Public Property PagesCount() As Integer
Public Get
End Get
Private Set
End Set
End Property
[C#]
public int PagesCount { public get; private set; }

See Also

XPSDocumentInfo Class | Conaito.XPS2Image Namespace


Path Property

conaito XPS2Image SDK 1.0

XPSDocumentInfo.Path Property

XPS file path

[Visual Basic]
Public Property Path() As String
Public Get
End Get
Private Set
End Set
End Property
[C#]
public string Path { public get; private set; }

See Also

XPSDocumentInfo Class | Conaito.XPS2Image Namespace


Conaito.XPS2Image.Exceptions

conaito XPS2Image SDK 1.0

Conaito.XPS2Image.Exceptions Namespace

Namespace Hierarchy

Classes

Class | Description
ConvertionException | Exception on convertion process
LicenseException | License info exception
PlayerFolderNotExistsException | Player folder not exists exception


ConvertionException Class

Exception on convertion process

For a list of all members of this type, see ConvertionException Members .

System.Object
Exception
ConvertionException

[Visual Basic]
<Serializable> _
Public Class ConvertionException
Inherits Exception
[C#]
[Serializable]
public class ConvertionException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.XPS2Image.Exceptions

Assembly: Conaito.XPS2Image (in Conaito.XPS2Image.dll)

See Also

ConvertionException Members | Conaito.XPS2Image.Exceptions Namespace


ConvertionException Members

ConvertionException overview

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Constructors

ConvertionException Constructor

Protected Instance Properties

HResult (inherited from Exception)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ConvertionException Class | Conaito.XPS2Image.Exceptions Namespace


ConvertionException Constructor

[Visual Basic]
Protected Overloads Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
ConvertionException(
SerializationInfo info,
StreamingContext context
);

See Also

ConvertionException Class | Conaito.XPS2Image.Exceptions Namespace


LicenseException Class

License info exception

For a list of all members of this type, see LicenseException Members .

System.Object
Exception
LicenseException

[Visual Basic]
<Serializable> _
Public Class LicenseException
Inherits Exception
[C#]
[Serializable]
public class LicenseException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.XPS2Image.Exceptions

Assembly: Conaito.XPS2Image (in Conaito.XPS2Image.dll)

See Also

LicenseException Members | Conaito.XPS2Image.Exceptions Namespace


LicenseException Members

LicenseException overview

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Constructors

LicenseException Constructor

Protected Instance Properties

HResult (inherited from Exception)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

LicenseException Class | Conaito.XPS2Image.Exceptions Namespace


LicenseException Constructor

[Visual Basic]
Protected Overloads Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
LicenseException(
SerializationInfo info,
StreamingContext context
);

See Also

LicenseException Class | Conaito.XPS2Image.Exceptions Namespace


PlayerFolderNotExistsException Class

Player folder not exists exception

For a list of all members of this type, see PlayerFolderNotExistsException Members .

System.Object
Exception
PlayerFolderNotExistsException

[Visual Basic]
<Serializable> _
Public Class PlayerFolderNotExistsException
Inherits Exception
[C#]
[Serializable]
public class PlayerFolderNotExistsException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.XPS2Image.Exceptions

Assembly: Conaito.XPS2Image (in Conaito.XPS2Image.dll)

See Also

PlayerFolderNotExistsException Members | Conaito.XPS2Image.Exceptions Namespace


PlayerFolderNotExistsException Members

PlayerFolderNotExistsException overview

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Constructors

PlayerFolderNotExistsException Constructor

Protected Instance Properties

HResult (inherited from Exception)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

PlayerFolderNotExistsException Class | Conaito.XPS2Image.Exceptions Namespace


PlayerFolderNotExistsException Constructor

[Visual Basic]
Protected Overloads Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
PlayerFolderNotExistsException(
SerializationInfo info,
StreamingContext context
);

See Also

PlayerFolderNotExistsException Class | Conaito.XPS2Image.Exceptions Namespace


Conaito.XPS2Image.Xml

conaito XPS2Image SDK 1.0

Conaito.XPS2Image.Xml Namespace

Namespace Hierarchy

Classes

Class | Description
XmlProperties |
XmlSlide |
XmlSlideCollection |
XmlSlideshow |


XmlProperties Class

For a list of all members of this type, see XmlProperties Members .

System.Object
XmlProperties

[Visual Basic]
<XmlType(AnonymousType:=False, IncludeInSchema:=True, TypeName:="properties", Namespace:="null")> _
Public Class XmlProperties
[C#]
[XmlType(AnonymousType=False, IncludeInSchema=True, TypeName="properties", Namespace="null")]
public class XmlProperties

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.XPS2Image.Xml

Assembly: Conaito.XPS2Image (in Conaito.XPS2Image.dll)

See Also

XmlProperties Members | Conaito.XPS2Image.Xml Namespace


XmlProperties Members

XmlProperties overview

Public Instance Constructors

XmlProperties Constructor Initializes a new instance of the XmlProperties class.

Public Instance Properties

Title

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

XmlProperties Class | Conaito.XPS2Image.Xml Namespace


XmlProperties Constructor

Initializes a new instance of the XmlProperties class.

[Visual Basic]
Public Sub New()
[C#]
XmlProperties();

See Also

XmlProperties Class | Conaito.XPS2Image.Xml Namespace


XmlProperties Properties

The properties of the XmlProperties class are listed below. For a complete list of XmlProperties class members, see the XmlProperties Members topic.

Public Instance Properties

Title

See Also

XmlProperties Class | Conaito.XPS2Image.Xml Namespace


Title Property

conaito XPS2Image SDK 1.0

XmlProperties.Title Property

[Visual Basic]
<XmlAttribute(Type:=null, AttributeName:="title", Namespace:="null", Form:=XmlSchemaForm.None)> _
Public Property Title() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlAttribute(Type=null, AttributeName="title", Namespace="null", Form=XmlSchemaForm.None)]
public string Title { public get; public set; }

See Also

XmlProperties Class | Conaito.XPS2Image.Xml Namespace


XmlSlide Class

For a list of all members of this type, see XmlSlide Members .

System.Object
XmlSlide

[Visual Basic]
<XmlType(AnonymousType:=False, IncludeInSchema:=True, TypeName:="slide", Namespace:="null")> _
Public Class XmlSlide
[C#]
[XmlType(AnonymousType=False, IncludeInSchema=True, TypeName="slide", Namespace="null")]
public class XmlSlide

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.XPS2Image.Xml

Assembly: Conaito.XPS2Image (in Conaito.XPS2Image.dll)

See Also

XmlSlide Members | Conaito.XPS2Image.Xml Namespace


XmlSlide Members

XmlSlide overview

Public Instance Constructors

XmlSlide Constructor Initializes a new instance of the XmlSlide class.

Public Instance Properties

Caption
Details
Height
Source
Width

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

XmlSlide Class | Conaito.XPS2Image.Xml Namespace


XmlSlide Constructor

Initializes a new instance of the XmlSlide class.

[Visual Basic]
Public Sub New()
[C#]
XmlSlide();

See Also

XmlSlide Class | Conaito.XPS2Image.Xml Namespace


XmlSlide Properties

The properties of the XmlSlide class are listed below. For a complete list of XmlSlide class members, see the XmlSlide Members topic.

Public Instance Properties

Caption
Details
Height
Source
Width

See Also

XmlSlide Class | Conaito.XPS2Image.Xml Namespace


Caption Property

conaito XPS2Image SDK 1.0

XmlSlide.Caption Property

[Visual Basic]
<XmlAttribute(Type:=null, AttributeName:="caption", Namespace:="null", Form:=XmlSchemaForm.None)> _
Public Property Caption() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlAttribute(Type=null, AttributeName="caption", Namespace="null", Form=XmlSchemaForm.None)]
public string Caption { public get; public set; }

See Also

XmlSlide Class | Conaito.XPS2Image.Xml Namespace


Details Property

conaito XPS2Image SDK 1.0

XmlSlide.Details Property

[Visual Basic]
<XmlElement(Type:=null, ElementName:="details", Namespace:="null", IsNullable:=False, Form:=XmlSchemaForm.None, Order:=-1)> _
Public Property Details() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlElement(Type=null, ElementName="details", Namespace="null", IsNullable=False, Form=XmlSchemaForm.None, Order=-1)]
public string Details { public get; public set; }

See Also

XmlSlide Class | Conaito.XPS2Image.Xml Namespace


Height Property

conaito XPS2Image SDK 1.0

XmlSlide.Height Property

[Visual Basic]
<XmlAttribute(Type:=null, AttributeName:="height", Namespace:="null", Form:=XmlSchemaForm.None)> _
Public Property Height() As Integer
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlAttribute(Type=null, AttributeName="height", Namespace="null", Form=XmlSchemaForm.None)]
public int Height { public get; public set; }

See Also

XmlSlide Class | Conaito.XPS2Image.Xml Namespace


Source Property

conaito XPS2Image SDK 1.0

XmlSlide.Source Property

[Visual Basic]
<XmlAttribute(Type:=null, AttributeName:="source", Namespace:="null", Form:=XmlSchemaForm.None)> _
Public Property Source() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlAttribute(Type=null, AttributeName="source", Namespace="null", Form=XmlSchemaForm.None)]
public string Source { public get; public set; }

See Also

XmlSlide Class | Conaito.XPS2Image.Xml Namespace


Width Property

conaito XPS2Image SDK 1.0

XmlSlide.Width Property

[Visual Basic]
<XmlAttribute(Type:=null, AttributeName:="width", Namespace:="null", Form:=XmlSchemaForm.None)> _
Public Property Width() As Integer
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlAttribute(Type=null, AttributeName="width", Namespace="null", Form=XmlSchemaForm.None)]
public int Width { public get; public set; }

See Also

XmlSlide Class | Conaito.XPS2Image.Xml Namespace


XmlSlideCollection Class

For a list of all members of this type, see XmlSlideCollection Members .

System.Object
CollectionBase
XmlSlideCollection

[Visual Basic]
<DefaultMember(MemberName:="Item")> _
Public Class XmlSlideCollection
Inherits CollectionBase
[C#]
[DefaultMember(MemberName="Item")]
public class XmlSlideCollection : CollectionBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.XPS2Image.Xml

Assembly: Conaito.XPS2Image (in Conaito.XPS2Image.dll)

See Also

XmlSlideCollection Members | Conaito.XPS2Image.Xml Namespace


XmlSlideCollection Members

XmlSlideCollection overview

Public Instance Constructors

XmlSlideCollection Constructor Initializes a new instance of the XmlSlideCollection class.

Public Instance Properties

Capacity (inherited from CollectionBase)
Count (inherited from CollectionBase)
Item

Public Instance Methods

Add
Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

Protected Instance Properties

InnerList (inherited from CollectionBase)
List (inherited from CollectionBase)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
OnClear (inherited from CollectionBase)
OnClearComplete (inherited from CollectionBase)
OnInsert (inherited from CollectionBase)
OnInsertComplete (inherited from CollectionBase)
OnRemove (inherited from CollectionBase)
OnRemoveComplete (inherited from CollectionBase)
OnSet (inherited from CollectionBase)
OnSetComplete (inherited from CollectionBase)
OnValidate (inherited from CollectionBase)

See Also

XmlSlideCollection Class | Conaito.XPS2Image.Xml Namespace


XmlSlideCollection Constructor

Initializes a new instance of the XmlSlideCollection class.

[Visual Basic]
Public Sub New()
[C#]
XmlSlideCollection();

See Also

XmlSlideCollection Class | Conaito.XPS2Image.Xml Namespace


XmlSlideCollection Properties

The properties of the XmlSlideCollection class are listed below. For a complete list of XmlSlideCollection class members, see the XmlSlideCollection Members topic.

Public Instance Properties

Capacity (inherited from CollectionBase)
Count (inherited from CollectionBase)
Item

Protected Instance Properties

InnerList (inherited from CollectionBase)
List (inherited from CollectionBase)

See Also

XmlSlideCollection Class | Conaito.XPS2Image.Xml Namespace


Item Property

conaito XPS2Image SDK 1.0

XmlSlideCollection.Item Property

[Visual Basic]
<XmlArrayItem(Type:=null, ElementName:="slide", Namespace:="null", NestingLevel:=0, IsNullable:=False, Form:=XmlSchemaForm.None)> _
Public Property Item( _
ByVal index As Integer _
) As XmlSlide
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlArrayItem(Type=null, ElementName="slide", Namespace="null", NestingLevel=0, IsNullable=False, Form=XmlSchemaForm.None)]
public XmlSlide this[
int index
] { public get; public set; }

See Also

XmlSlideCollection Class | Conaito.XPS2Image.Xml Namespace


XmlSlideCollection Methods

The methods of the XmlSlideCollection class are listed below. For a complete list of XmlSlideCollection class members, see the XmlSlideCollection Members topic.

Public Instance Methods

Add
Clear (inherited from CollectionBase)
Equals (inherited from Object)
GetEnumerator (inherited from CollectionBase)
GetHashCode (inherited from Object)
GetType (inherited from Object)
RemoveAt (inherited from CollectionBase)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
OnClear (inherited from CollectionBase)
OnClearComplete (inherited from CollectionBase)
OnInsert (inherited from CollectionBase)
OnInsertComplete (inherited from CollectionBase)
OnRemove (inherited from CollectionBase)
OnRemoveComplete (inherited from CollectionBase)
OnSet (inherited from CollectionBase)
OnSetComplete (inherited from CollectionBase)
OnValidate (inherited from CollectionBase)

See Also

XmlSlideCollection Class | Conaito.XPS2Image.Xml Namespace


XmlSlideCollection.Add Method

[Visual Basic]
Public Sub Add( _
ByVal xmlSlide As XmlSlide _
)
[C#]
public int Add(
XmlSlide xmlSlide
);

See Also

XmlSlideCollection Class | Conaito.XPS2Image.Xml Namespace


XmlSlideshow Class

For a list of all members of this type, see XmlSlideshow Members .

System.Object
XmlSlideshow

[Visual Basic]
<XmlRoot(ElementName:="slideshow", Namespace:="null", IsNullable:=True)> _
Public Class XmlSlideshow
[C#]
[XmlRoot(ElementName="slideshow", Namespace="null", IsNullable=True)]
public class XmlSlideshow

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.XPS2Image.Xml

Assembly: Conaito.XPS2Image (in Conaito.XPS2Image.dll)

See Also

XmlSlideshow Members | Conaito.XPS2Image.Xml Namespace


XmlSlideshow Members

XmlSlideshow overview

Public Instance Constructors

XmlSlideshow Constructor Initializes a new instance of the XmlSlideshow class.

Public Instance Properties

Properties
Slides

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

XmlSlideshow Class | Conaito.XPS2Image.Xml Namespace


XmlSlideshow Constructor

Initializes a new instance of the XmlSlideshow class.

[Visual Basic]
Public Sub New()
[C#]
XmlSlideshow();

See Also

XmlSlideshow Class | Conaito.XPS2Image.Xml Namespace


XmlSlideshow Properties

The properties of the XmlSlideshow class are listed below. For a complete list of XmlSlideshow class members, see the XmlSlideshow Members topic.

Public Instance Properties

Properties
Slides

See Also

XmlSlideshow Class | Conaito.XPS2Image.Xml Namespace


Properties Property

conaito XPS2Image SDK 1.0

XmlSlideshow.Properties Property

[Visual Basic]
<XmlElement(Type:=null, ElementName:="properties", Namespace:="null", IsNullable:=False, Form:=XmlSchemaForm.None, Order:=-1)> _
Public Property Properties() As XmlProperties
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlElement(Type=null, ElementName="properties", Namespace="null", IsNullable=False, Form=XmlSchemaForm.None, Order=-1)]
public XmlProperties Properties { public get; public set; }

See Also

XmlSlideshow Class | Conaito.XPS2Image.Xml Namespace


Slides Property

conaito XPS2Image SDK 1.0

XmlSlideshow.Slides Property

[Visual Basic]
<XmlElement(Type:=null, ElementName:="slide", Namespace:="null", IsNullable:=False, Form:=XmlSchemaForm.None, Order:=-1)> _
Public Property Slides() As XmlSlideCollection
Public Get
End Get
Public Set
End Set
End Property
[C#]
[XmlElement(Type=null, ElementName="slide", Namespace="null", IsNullable=False, Form=XmlSchemaForm.None, Order=-1)]
public XmlSlideCollection Slides { public get; public set; }

See Also

XmlSlideshow Class | Conaito.XPS2Image.Xml Namespace


Conaito.XPS2Image.ExceptionsHierarchy

conaito XPS2Image SDK 1.0

Conaito.XPS2Image.Exceptions Hierarchy

Object
Exception ---- ISerializable
ConvertionException
LicenseException
PlayerFolderNotExistsException

See Also

Conaito.XPS2Image.Exceptions Namespace


Conaito.XPS2Image.XmlHierarchy

conaito XPS2Image SDK 1.0

Conaito.XPS2Image.Xml Hierarchy

Object
XmlProperties
XmlSlide
XmlSlideshow
CollectionBase ---- ICollection, IEnumerable, IList
XmlSlideCollection

See Also

Conaito.XPS2Image.Xml Namespace


Conaito.XPS2ImageHierarchy

conaito XPS2Image SDK 1.0

Conaito.XPS2Image Hierarchy

Object
ConvertingSettings
XPSConverter
XPSDocumentInfo
ValueType
Enum ---- IComparable, IConvertible, IFormattable
ImageFormat
ImageQuality

See Also

Conaito.XPS2Image Namespace